Additional space appears when changing display styles by JavaScript.

RESOLVED DUPLICATE of bug 97506

Status

()

Core
DOM: CSS Object Model
RESOLVED DUPLICATE of bug 97506
16 years ago
16 years ago

People

(Reporter: Michael Kremser, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
In the example above you can see that there appears an additional space if you 
toggle a table row's "style.display" between "block" and "none" (by pressing the
buttons).

Comment 1

16 years ago
Created attachment 101081 [details]
valid testcase

Table elements should not have "display" equal to "inline" or "block".	See
http://www.w3.org/TR/REC-CSS2/visuren.html#display-prop

setting the <tr> to "table-row" and "none" works fine
Yep, true.  That said, we could handle this more gracefully....

*** This bug has been marked as a duplicate of 97506 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
actually, this seems to be the opposite of bug 97506 (setting a <div> to have
'table-row').  Also, the original bug 97506 is WFM
You need to log in before you can comment on or make changes to this bug.