Closed Bug 1715934 Opened 1 year ago Closed 1 year ago

firefox hangs randomly since update 89.0 [WebRenderLayerManager::FlushRendering()]

Categories

(Core :: Graphics: WebRender, defect)

Firefox 89
defect

Tracking

()

RESOLVED DUPLICATE of bug 1708224

People

(Reporter: nuromi, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

browse the web

Actual results:

firefox hangs completely at random times and starts using 100% of one of my cpu's leaving me no choice but to kill it.
this can happen on any website at any time, it has happened both in my old profile and in a newly created one (with addons).

I am using Debian Bullseye with the Mozilla binaries from their website, has happened in both xfce and kde plasma desktop environments. Never occurred before 89.0 update, i am currently using firefox-esr from debian repos and this problem does not occur.

Expected results:

browsing the web without hangs

I have followed this guide
https://developer.mozilla.org/en-US/docs/Mozilla/How_to_report_a_hung_Firefox
and sent a crash report after firefox hung up again, here it is
https://crash-stats.mozilla.org/report/index/0867f998-8e18-41cd-baf6-7f2820210610

And i have found more bug reports that are similar to this
bug #1714360
bug #1714199
bug #1711016
bug #1712620
bug #1715829
bug #1712561

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Flags: needinfo?(nuromi)

Turning off hardware acceleration does not work and I was able to reproduce the bug in a newly created profile without addons, i even delete the .mozilla folder and start over with no results.
There seems to be some progress on this in here bug #1712561

Flags: needinfo?(nuromi)

my mistake, i thought i had tried it with hardware acceleration disabled but i didn't, i'm testing it now with no hangs at the moment.

yes, it just hung right now, disabling hardware acceleration doesn't work.
I made another crash report of the hang, here it is:
https://crash-stats.mozilla.org/report/index/3d55cbe0-b4fb-464f-a60e-9d5750210612

Same problem for me - Firefox 89 hangs sometimes after start for some seconds.
I noticed that Firefox hangs as long as Firefox is searching for updates in background (status can be monitored in settings 'Firefox Update'). After that (Firefox is up to date) everything works properly.
Hope that issue can be fixed quick in the next release.

Same here (so far I think video content has been playing each time it happened). 100% main process CPU usage. I have lots of windows/tabs and some extensions though.

In my case, it happens whether a video is playing or not.
I recently installed manjaro on the same machine and the hangs also happen here with firefox from the manjaro repositories.
Here is another crash report in case it helps: https://crash-stats.mozilla.org/report/index/00266645-938f-4e44-b462-6ce1a0210614.

Attached file about:support

I am attaching my about:support info.

Attached file about:support-raw

from bug #1712561, comment 27

Looking at the bugs listed in comment 11 the first thing that comes to my mind are freeze reports concerning SW-WR. There are a bunch of systems that went from Basic to Webrender or Webrender (software) in the 89 release on Linux - should be possible to check if the same happens with gfx.webrender.force-disabled.

I set gfx.webrender.force-disabled to true in about:config and testing it right now, so far without freezes/hangs.

Firefox 89.0.1 have still the same problem :(
Some seconds after start - Firefox hangs for ~1 Minutes - no page is loading - until the timer stops rotating...

Jackek: if it eventually stops hanging and it only happens after start it might be bug #1713129 instead

(In reply to nuromi from comment #12)

from bug #1712561, comment 27

Looking at the bugs listed in comment 11 the first thing that comes to my mind are freeze reports concerning SW-WR. There are a bunch of systems that went from Basic to Webrender or Webrender (software) in the 89 release on Linux - should be possible to check if the same happens with gfx.webrender.force-disabled.

I set gfx.webrender.force-disabled to true in about:config and testing it right now, so far without freezes/hangs.

According to https://crash-stats.mozilla.org/report/index/0867f998-8e18-41cd-baf6-7f2820210610

it's freeze at

mozilla::layers::WebRenderLayerManager::FlushRendering()

Component: Widget: Gtk → Graphics: WebRender
Summary: firefox hangs randomly since update 89.0 → firefox hangs randomly since update 89.0 [WebRenderLayerManager::FlushRendering()]

(In reply to olejorgenb from comment #14)

Jackek: if it eventually stops hanging and it only happens after start it might be bug #1713129 instead

No, my issue with Firefox89 happens not only after Firefox update - but reproducible after every start of Firefox :(

Bumping to S2 because we're finding many reports of this spread through various bugs, and this is in release, on a smaller user population, so this might be scarily common.

Severity: -- → S2

Firefox still freezes in 89.0.1 without gfx.webrender.force-disabled set to true

For anyone who's experiencing reproducible hangs can you try running mozregression to determine what change caused the problem?

Blocks: 1717105

(In reply to Jeff Muizelaar [:jrmuizel] from comment #19)

For anyone who's experiencing reproducible hangs can you try running mozregression to determine what change caused the problem?

I try to execute Mozregression but it doesn't work with the issue...
Settings

  • Last known bad build: 89
  • First known good build: 88
    Leads Mozregression to an error message: The first date must be earlier than the second one.

(In reply to Jacek from comment #20)

(In reply to Jeff Muizelaar [:jrmuizel] from comment #19)

For anyone who's experiencing reproducible hangs can you try running mozregression to determine what change caused the problem?

I try to execute Mozregression but it doesn't work with the issue...
Settings

  • Last known bad build: 89
  • First known good build: 88
    Leads Mozregression to an error message: The first date must be earlier than the second one.

OK - Mozregression works now fine - have to use setting 'search for regression' ..... ;)

Just for your info - To fix the issue with hanging Firefox89 - I have to stop my Antivirus - then Firefox 89 works fine smoothly again!
Excluding only directory with Firefox in my Antivirus does not help :( There must be something striking in the Firefox89 code that alert the Antivirus ...
PS. I will stay for now on FirefoxESR first.

I have a feeling my bug report (https://bugzilla.mozilla.org/show_bug.cgi?id=1717345) is related to this one.

Just for your info - To fix the issue with hanging Firefox89 - I have to stop my Antivirus - then Firefox 89 works fine smoothly again!

Jacek, 2 questions:

a) Are you on Linux? And if so, which distro?
b) Which Antivirus product is this?

Flags: needinfo?(Jacek)

(In reply to Gian-Carlo Pascutto [:gcp] from comment #24)

Just for your info - To fix the issue with hanging Firefox89 - I have to stop my Antivirus - then Firefox 89 works fine smoothly again!

Jacek, 2 questions:

a) Are you on Linux? And if so, which distro?
b) Which Antivirus product is this?

I am using WIndows 7 and 10 with Avast Antivirus - Firefox 89.0.1 hangs.
WIndows 10 with Defender Antivirus (and Cybereason) works fine with Firefox 89.0.1

PS. Maybe Avast can fix the trouble faster with next update ;)

Flags: needinfo?(Jacek)

Since firefox 89.0.2 I have not experienced any more hangs.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1708224
You need to log in before you can comment on or make changes to this bug.