Status

()

enhancement
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: ipgliter, Assigned: bugs)

Tracking

unspecified
Firebird0.8
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
The browser offers an history access in tools but it not includes the posibility
of working offline. Is it to be implemented in future versions?.

Comment 1

17 years ago
This isn't likely to happen any time soon. Hyatt has said that he'd like to get
off-line working sometime so ->hyatt.
Assignee: blaker → hyatt
Status: UNCONFIRMED → NEW
Ever confirmed: true
Well, you can start Phoenix offline via the Profile Manager; or you can open the
JavaScript console and evaluate the following expression (on one line):
Components.classes['@mozilla.org/network/io-service;1']
.getService(Components.interfaces.nsIIOService).offline = true;

Updated

17 years ago
Summary: work offline → Implement work offline
Target Milestone: --- → Phoenix0.5

Updated

17 years ago
Target Milestone: Phoenix0.5 → Phoenix0.6

Updated

17 years ago
Severity: normal → enhancement

Comment 3

17 years ago
Thank you commenter #2. Anyway I can execute that statement outside of the
console? My idea is that if this can be so simply executed from the Javascript
console, then it should be pretty easy to implement this. Or I could do it
myself with PrefBar.
You will need XPConnect privileges to execute that line of script.

Updated

17 years ago
OS: Windows 98 → All

Comment 5

17 years ago
add ui keyword?

Comment 6

16 years ago
hyatt knows what to do here to make this work. Maybe for 0.7
Target Milestone: Phoenix0.6 → Phoenix0.7

Comment 7

16 years ago
Is this the same sort of thing as starting at a certain page, spidering out "x"
number of links, saving those links to the harddrive in a temp directory on
local harddrive, logging out and then having those pages available for browsing
when not connected to the net?  It would be super handy to have that for laptops...

Comment 8

16 years ago
Shouldn't this be an extension like Thunderbird has?

Comment 9

16 years ago
Is this feature really still needed?

We can change status online <-> offline very natural and transparent.
Thus users don't need to consider if it's online or offline.

Comment 10

16 years ago
Natural and transparent? In Mozilla, yes. But Firebird neither has the statusbar
icon nor the menu entry. It's a bit more complicated. Have a look at comment 2!
I prefer the nice Javascript hack. ;-)

Comment 11

16 years ago
i rarely did use it in IE and I really don't need to view cached pages

its still a lot more useful than stupid cut/copy/paste buttons

Comment 12

16 years ago
Has anyone looked into expanding/duplicating the extension mentioned in comment 8?

Comment 13

16 years ago
The Thunderbird extension can be found here:
http://texturizer.net/thunderbird/extensions.html#Offline

Updated

16 years ago
Target Milestone: Firebird0.7 → Firebird0.8

Comment 14

16 years ago
*** Bug 215751 has been marked as a duplicate of this bug. ***

Updated

16 years ago
QA Contact: asa

Comment 15

16 years ago
i think an extension for this has been made by "pike" and it works great
you can find it at:

http://pike.p5.org.uk/mozilla/#wo

Comment 17

16 years ago
Since there's an extension for this, I recommend marking this WONTFIX.  People
that want offline functionality can use the extension.

Comment 18

16 years ago
Just because there is an extension, doesn't mean that this shouldn't be
implemented.  The presence of an extension along with 40 votes allocated to this
'bug' suggests to me that it might be nice to have this in the default install.
If there's an extension, then the feature *is* implemented.  You want it
bundled. I think that's reasonable.  Ben?

/be
Assignee: hyatt → bugs

Comment 20

16 years ago
Seems to me from the earlier comments in this bug that this has already been
planned for inclusion by default -- why would the availablity of an extension
change this?  Autoscroll and the styleswitcher came directly from extensions.

Comment 21

16 years ago
FWIW: Let me add that both extensions mentioned here (in comments #15 and #16)
do not currently seem to work with (some?) localized builds of FB. Installing
them in the German FB 0.7 just results in the status bar being replaced by a big
panel containing the text "<menuitem ...." in a red font (don't have the full
text right now as I haven't got the German build on this machine).

Comment 22

16 years ago
Quoting the Firebird charter:
"...The goal was, and is not to have more or less features than any other client
(Mozilla included) but to have the right set of features to let people get their
jobs done..."

Many users all over the world still connect to the internet via dialup. For
those users who do not spend a long period of time on the internet, or for whom
limited ISP choice is available, billing is per unit time, rather than flat
rate. Thus for many users it is IMPERATIVE that it is possible to view cached
pages offline, minimising time online without having to explicitly save each and
every page viewed.

This feature requires a minimum level of functionality:
1) Switch online/offline without needing to restart the browser
2) Automatically work offline if a page is uncached, and a connection is neither
available nor permitted by the user.
3) Automatically work offline if a page is uncached, and a connection is not
available, but permitted by the user.
4) Indicate in some manner which links and history items are unavailable when
working offline, otherwise (2) and (3) would keep pestering the user.

Relying on the extension mechansim currently has the following shortcomings:
a) Only (1) is implemented.
b) Clicking a link whilst "working online" with no connection available destroys
the cached page.
c) (2), (3) and (4) are not implemented.
d) Pike has indicated that there is no immediate prospect of future development
on his extension.
e) The extension is not listed on the main extensions page
f) Most of our target audience (many of whom are IE users) will never change the
default settings, and will most likely never even see the profile dialog. They
will therefore be under the impression that Firebird does not support offline
working.

Although points (a) - (e) are fixable, point (f) is fatal when combined with the
Firebird Charter and the requirement for this feature when working over dialup.
I would like to support some of the points above by observing that:
i)  This feature has been repeatedly requested in MZ forums, despite several
threads on the same page about it and the existence of an extension.
ii) There are now over 40 votes for this feature.
iii) This feature requires only a single menu item, and almost all the required
code is already in the core. This feature will therefore bloat neither interface
nor codebase.
iv) This feature is offered by Mozilla, Netscape, Internet Explorer, Navigator
and Opera, to name but a few. Users migrating from these browsers will be
expecting to see this feature.

To summarize:
This feature is vital for many dialup users, and present in rival browsers. I
believe the Firebird Charter requires its inclusion on the first point alone,
and by the second leaving it out will result in a reduction in potential user
base. I have also stated a number of discrete points in favour of the change.
Fixed. 
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED

Comment 24

16 years ago
Ben's comment 23 marked this as fixed - but I don't see any mention of a patch.

Does this mean it will be "fixed" by bundling an extension in the default
installation?

What about the possible bug(s) raised in comment 21 about the extension(s)
breaking under localised builds?

Comment 25

16 years ago
Re: Comment 21
I am the extension's author pointed in comment #16.
Your problem doesn't occurs for me (with contributed 0.7 de-DE build, clean
profile and offline ext. I made).

Re: Comment 24
The offline feature is implemented. See:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&dir=mozilla%2Fbrowser+mozilla%2Ftoolkit&sortby=Date&date=explicit&mindate=12%2F01%2F2003+16%3A29&maxdate=12%2F01%2F2003+16%3A59&cvsroot=%2Fcvsroot

Comment 26

16 years ago
Peter: the main Firebird devs don't have to attach a patch before fixing
something, as they don't have to get a review.  See
http://www.mozilla.org/projects/firebird/review.html

Comment 27

16 years ago
*** Bug 231693 has been marked as a duplicate of this bug. ***
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.