Closed Bug 1716022 Opened 1 month ago Closed 1 month ago

Return pages in the messages API as soon as they are ready, and not after the last page has been finished.

Categories

(Thunderbird :: Add-Ons: Extensions API, enhancement)

Thunderbird 90
enhancement

Tracking

(thunderbird_esr78 wontfix)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- wontfix

People

(Reporter: TbSync, Assigned: TbSync)

References

Details

Attachments

(2 files)

No description provided.
Attached file query.xpi

Example add-on to demonstrate a simple query.

Removing checkin-needed to discuss alternatives, as this still does not fix the issue for a search with a single match. Even with page size set to 1, all messages have to be checked, because the pagination system needs to know if there is a second page, in order to include the page id in the first page or not.

The remaining issues will be handled in bug 1716737.

Status: NEW → ASSIGNED
Target Milestone: --- → 91 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/39a86b4a895e
Return message pages as soon as they are available. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Regressions: 1717348
You need to log in before you can comment on or make changes to this bug.