Closed Bug 1716068 Opened 2 months ago Closed 1 month ago

autoscroll is no longer compatible with middle button paste into contenteditable

Categories

(Core :: DOM: Editor, defect, P2)

Firefox 91
Desktop
All
defect

Tracking

()

RESOLVED FIXED
91 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox89 --- wontfix
firefox90 --- fixed
firefox91 --- fixed

People

(Reporter: dennis.lissov, Assigned: masayuki)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Start Firefox on Linux, enable autoscroll.
Select some text in some application to put it in the primary selection buffer.
Open a webpage that has a contenteditable area, like the following fiddle: https://jsfiddle.net/gdqb7pzj/
Middle-click in the area to paste the primary selection.

Actual results:

This used to work, but since Firefox 89 it does not work, and mozregression points to bug 1528289.

Expected results:

Linux apps should support the primary selection buffer. Normally middle-click is the only way to paste its contents, so this change forces users to either remember which webpages work with it, or just remember that Firefox does not support the primary selection buffer at all.

The Bugbug bot thinks this bug should belong to the 'Core::DOM: Editor' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → DOM: Editor
Product: Firefox → Core

Based on comment #0, set tracking flags accordingly.

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Keywords: regression
OS: Unspecified → Linux
Regressed by: 1528289
Hardware: Unspecified → Desktop

Indeed. This is reproducible on any platforms with enabling middle click paste with the pref.

Assignee: nobody → masayuki
Severity: -- → S3
Status: NEW → ASSIGNED
OS: Linux → All
Priority: -- → P2

When middle mouse paste is enabled and middle click occurs in an editable
content or it's in a document whose designMode is on, we shouldn't start
the autoscrolling because the click must be intended for pasting clipboard
content or primary selection to the position.

Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/ea4676809c9f
Don't start autoscroll on editable content or document whose designMode is on r=smaug
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

Comment on attachment 9227344 [details]
Bug 1716068 - Don't start autoscroll on editable content or document whose designMode is on r=smaug!

Beta/Release Uplift Approval Request

  • User impact if declined: Linux users cannot use middle click paste in rich text editor if autoscroll is enabled.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This blocks to start autoscroll if and only if middle click paste is enabled (enabled by default only on Linux) and clicked document or element is editable.
  • String changes made/needed:
Attachment #9227344 - Flags: approval-mozilla-beta?

Ah, but autoscroll is disabled by default only on Linux.
https://searchfox.org/mozilla-central/rev/5e955a47c4af398e2a859b34056017764e7a2252/browser/app/profile/firefox.js#245

I'm not sure how many users are victims of this regression.

Comment on attachment 9227344 [details]
Bug 1716068 - Don't start autoscroll on editable content or document whose designMode is on r=smaug!

approved for 90.0b9

Attachment #9227344 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.