Closed Bug 1716085 Opened 8 months ago Closed 7 months ago

Shift + middle mouse click selects text

Categories

(Core :: DOM: Events, defect)

Firefox 89
Desktop
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1715603
Tracking Status
firefox-esr78 --- unaffected
firefox89 --- wontfix
firefox90 --- wontfix
firefox91 --- affected

People

(Reporter: tomorrowcheck, Unassigned)

References

(Regression)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

  1. Select any text on a webpage or visit any link
  2. Press shift + middle mouse click on a link to open it in a new tab and switch to it immediately
  3. Return to the original page

Actual results:

Firefox has selected the text from where the user first clicked to where the user used shift + middle mouse click.

Expected results:

Text should not be selected when using shift in combination with a middle mouse click.

Note: The change was introduced in the current version. It is particularly noticeable when a user has enabled "When you open a link in a new tab, switch to it immediately" and shift + middle mouse is used to occasionally open links in the background. It results in text being selected while opening links in the background, which hinders the readability of the original page.

I can reproduce the issue on Nightly91.0a1 Windows10.

Simple steps to reproduce:

  1. Enabled "When you open a link in a new tab, switch to it immediately" in settings
  2. Open web page in [Tab A] (e.g. https://ftp.mozilla.org/pub/firefox/nightly/)
  3. Middle-click on a link(e.g. 2004) so that the link opens in a new foreground tab
  4. Back to previous tab[Tab A]
  5. Shift + Middle-click on the other link(e.g. 2010) so that the link opens in a new background tab

Actual Results:
Text is unexpectedly selected.

Expected Results:
Text should not be selected.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2032f2b926ddf13702d5720983d226273a4290a6&tochange=889132330748b03914570e29abbb56950816da30

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → DOM: Events
Ever confirmed: true
Keywords: regression
OS: Unspecified → All
Product: Firefox → Core
Regressed by: 1528289
Hardware: Unspecified → Desktop

I believe this issue is a duplicate of Bug 1715603

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1715603
You need to log in before you can comment on or make changes to this bug.