Closed Bug 17161 Opened 21 years ago Closed 21 years ago

View|Sidebar checkbox is backwards when default is open

Categories

(SeaMonkey :: Sidebar, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 17347

People

(Reporter: dbaron, Assigned: slamm)

Details

DESCRIPTION:  I permamently closed my sidebar a while ago by unchecking
View|Sidebar.  However, some (I think a little more than 50%) of the time, when
I start apprunner, the sidebar comes up open.  (However, there's no check mark
on the menu, and toggling the menu keeps the check mark exactly the reverse of
reality.)  I would suspect this is some sort of a timing bug...

STEPS TO REPRODUCE:

 * Select View | Sidebar so the sidebar is closed, and a pref is set so it
stays closed

 * Launch apprunner, possibly many times (it's hard to reproduce)

ACTUAL RESULTS:
 * sometimes, the sidebar comes up open, as described above

EXPECTED RESULTS:
 * sidebar always closed

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-10-24-08-M11
Summary: sidebar doesn't always respect pref → sidebar doesn't respect pref
OK - I see what's happening now.  There are two problems:

 * the sidebar state pref doesn't work at all anymore (a regression)
 * the View|Sidebar box is initially unchecked, but the sidebar is initially
open.


The reason I thought the pref was working sometimes was that when I closed the
sidebar and opened a new window, the sidebar was closed and everything was in
sync.
the open/close pref not being persistent is covered under bug 13901. I'm not
sure how the checkmark is supposed to work.
I was talking about the "View | Sidebar" no longer being persistent (it's a
different, but similar, problem).  I think that broke when the sidebar switched
to being an XUL overlay.
okay, I really meant bug 16516 :-)
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Paul is right this is a duplicate of bug 16516.

The hiding of the sidebar is no longer done with preferences. It uses XUL
persistence. Unfortunately, persistence does not work when the app crashes, or
fails to shutdown properly.

*** This bug has been marked as a duplicate of 16516 ***
Status: RESOLVED → VERIFIED
Verified duplicate.
Status: VERIFIED → REOPENED
Summary: sidebar doesn't respect pref → View|Sidebar checkbox is backwards when default is open
I'm reopening this because only half of it was a duplicate.  The bit about the
checkbox being reversed is still not fixed.  *If* your default sidebar state is
open, then the checkbox is always reversed.  (That is, if the window opens
showing a sidebar, then the checkbox is initially unchecked.)
Resolution: DUPLICATE → ---
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → DUPLICATE
I have a fix ready.

*** This bug has been marked as a duplicate of 17347 ***
Status: RESOLVED → VERIFIED
[bugday] verifying duplicity (of two parent dupe bugs)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.