Closed Bug 1716131 Opened 4 months ago Closed 3 months ago

Remove rdf.js from cZ and some minor tidy up

Categories

(SeaMonkey :: Chat, task)

Tracking

(seamonkey2.53+ fixed)

RESOLVED FIXED
seamonkey 2.88
Tracking Status
seamonkey2.53 + fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Details

(Whiteboard: SM2.53.9)

Attachments

(1 file)

suite/extensions/irc/xul/content/rdf.js is not packaged or in use in chatZilla so can be removed. Also found a few more areas where cZ checks for older APIs / functions which can be removed.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: none
Testing completed (on m-c, etc.): 2.53.9
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Attachment #9226651 - Flags: review?(frgrahl)
Attachment #9226651 - Flags: approval-comm-release?
Attachment #9226651 - Flags: approval-comm-esr60?

Comment on attachment 9226651 [details] [diff] [review]
1716131-irc-remove-rdfjs-2539.patch

LGTM

Attachment #9226651 - Flags: review?(frgrahl)
Attachment #9226651 - Flags: review+
Attachment #9226651 - Flags: approval-comm-release?
Attachment #9226651 - Flags: approval-comm-release+
Attachment #9226651 - Flags: approval-comm-esr60?
Attachment #9226651 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/c1554e65fce8
Remove rdf.js from cZ and some minor tidy up. r=frg

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Whiteboard: SM2.53.9
Target Milestone: --- → seamonkey 2.88
You need to log in before you can comment on or make changes to this bug.