Closed Bug 1716223 Opened 3 months ago Closed 3 months ago

ALT-B <right-click bookmark> P is no longer the keyboard shortcut to change the properties of a bookmark

Categories

(Firefox :: Bookmarks & History, defect)

Firefox 89
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox89 --- affected
firefox90 --- affected
firefox91 --- affected

People

(Reporter: stine2469, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

open firefox (by any method)
click ALT-B (using keyboard)
right-click bookmark (using mouse)
type P (using keyboard)

Actual results:

Nothing

Expected results:

The properties of the bookmark should have opened in the Bookmark editor.

What did happen is that someone who NEVER USES KEYBOARD SHORTCUTS changed something again, for no reason at all.

The Bugbug bot thinks this bug should belong to the 'Firefox::Bookmarks & History' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Bookmarks & History

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Hi,

I am able to reproduce the issue in release 89, beta 90.0b7 and latest nightly 91.0a1 (2021-06-14) using Windows 10. Also this is not a regression since I am able to reproduce it in Fx 62.0a1 (2018-06-02) as well. I am not sure if this is an issue or maybe it could be an enhancement. I will set this as New and waiting for the developers opinion.

Thanks for your input.

Status: UNCONFIRMED → NEW
Ever confirmed: true

In which locale is your Firefox? The shortcuts are per locale, and recently various shortcuts changed for new design requirements.
That was an intentional change, and it's similar to others that were made at the same time in Firefox 89.
Changing again would break people who got used to the new access key, so there's no win-win solution. I fear this ends up being a wontfix, we could not change it again without a PM request, because the original change has been made for UX reasons, reverting should similarly be done for good reasons, and since we already broke muscle memory, that reason is not spendable.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.