Unexpected text highlight

VERIFIED WORKSFORME

Status

Tech Evangelism Graveyard
Italian
VERIFIED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Andrea Aime, Assigned: Tristan Nitot)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020926
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020926

If you pass the mouse cursor over the article content
if will be hightlighted (turns to red). This should 
not happen, and does not happen in IE 6.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
This seems to be a tech evangelism bug.

When page is loaded, there is a JS script inside the page, sniffing what browser
is used, and loading good css for browser.

"// questa parte fa il check del font
if (navigator.appVersion.toLowerCase().indexOf('mac') !=-1) {
	if ((navigator.appName == "Microsoft Internet Explorer") &&
(parseInt(navigator.appVersion) > 3 )) 
		{
   			//alert("MAC IE");
   			document.write("<LINK REL=stylesheet HREF='/common/_css/pro/stampa_IE.css'
TYPE='text/css'>"); 
   		}
//	else if((navigator.appName == "Netscape") && (parseInt(navigator.appVersion)
> 3 )) 
		else
		{
			//alert("MAC NS");
			document.write("<link rel=stylesheet href='/common/_css/pro/stampa_MACNS.css'
type='text/css'>"); 
		}
}else { 
	if ((navigator.appName == "Microsoft Internet Explorer") &&
(parseInt(navigator.appVersion) >= 3 )) 
		{
   			//alert("PC IE");
   			document.write("<LINK REL=stylesheet HREF='/common/_css/pro/stampa_IE.css'
TYPE='text/css'>"); 
   		}
//	else if ((navigator.appName == "Netscape") && (parseInt(navigator.appVersion)
>= 3 )) 
		else
		{
			//alert("PC NS");
			document.write("<link rel=stylesheet href='/common/_css/pro/stampa_NS.css'
type='text/css'>"); 
		}
}
</script>"

Confirming this bug, using trunk build 2002092904 - WinXP
Assignee: asa → nitot
Status: UNCONFIRMED → NEW
Component: Browser-General → Europe: West
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: asa → brantgurganus2001
Version: other → unspecified
(Reporter)

Comment 2

15 years ago
Can't reproduce it anymore on the lastampa web site.
Closing the bug.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 3

15 years ago
OK. If you don't see this bug, I won't open it back ;-)

Comment 4

15 years ago
v
Status: RESOLVED → VERIFIED

Comment 5

15 years ago
tech evang june 2003 reorg
Component: Europe: West → Italian
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.