Closed Bug 1716594 Opened 6 months ago Closed 4 months ago

Investigate if requestedIndex should be cleared when doing a replace load

Categories

(Core :: DOM: Navigation, task, P3)

task

Tracking

()

RESOLVED WORKSFORME
Fission Milestone MVP
Tracking Status
firefox92 --- affected

People

(Reporter: smaug, Assigned: smaug)

References

(Blocks 1 open bug)

Details

(Whiteboard: fission-hard-blocker)

Attachments

(1 file)

This is related to bug 1697905.
We have no known bug reports about this, so need to try to write a testcase.
But it isn't clear yet, whether there is a bug.

This bug is a hard blocker for Fission MVP.

Whiteboard: fission-hard-blocker
Summary: Investigate is requestedIndex should be cleared when doing a replace load → Investigate if requestedIndex should be cleared when doing a replace load

Looks like the code below does similar thing already for iframes, so this is adding InternalSetRequestedIndex
call only for the top level case.
This is based on the same assumptions as bug 1697905, but unfortunately testing this is still
super hard.

Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/94d021b67f6f
clear the requested index after replacing an entry, r=peterv
Regressions: 1725458
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

the failure got me looking at this some more, and my current understanding is that we don't need this (this is basically handled already).

Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Flags: needinfo?(bugs)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.