After entering bug data, if an error occured, bug data is not stored on the host

RESOLVED DUPLICATE of bug 179330

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 179330
16 years ago
15 years ago

People

(Reporter: Garrett Smith, Assigned: myk)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826

If I file a bug but forget to choose a component, as I did a few minutes ago,
the information will be lost forever and I am forced to type it in again.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. fill out bug report form with a lot of information, 9 steps, big summary, et c.
2. Do not enter a component!
2. click submit
3. the bug will not be filed. You'll get a message saying 'Use Back Button'


Actual Results:  
Pushing Back button brought me to http://bugzilla.mozilla.org/enter_bug.cgi and
all fields were blank.

Expected Results:  
A property bound to the session: lastBugData.
A property bound to the session: hasError

Possibly assign a bug number to the incomplete bug and then have the user fill
in the component.

At the very least, bugzilla should provide a javascript alert/prompt that
prevents the user from submitting the incomplete form. Ideally, bugzilla should
do redundant checking -once on the client, once on the host.


I have to still file the bug that I originally wanted to file. Since I have
don't have time, I won't. Bugzilla kept me from filing the bug.

Comment 1

16 years ago
*** Bug 171697 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Assignee: asa → myk
Component: Browser-General → Creating/Changing Bugs
Product: Browser → Bugzilla
QA Contact: asa → matty
Summary: After entering bug data, if an error occured, bug data is not stored on the host → After entering bug data, if an error occured, bug data is not stored on the host
Version: other → 2.10

Comment 2

16 years ago
Reassigning to Bugzilla/"Creating/Changing Bugs".

Garrett, can you reproduce this using other browsers than Mozilla?

Comment 3

16 years ago
I just tried this on bugzilla.mozilla.org and it does not do this with either
the guided or non-guided version.

I am using Mozilla Build 2002053012

Please try to reproduce with another browser.  If the other browser does not
show this problem, then reopen as a browser bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

16 years ago
Well, you all misunderstood apparently, so I'll try to explain better. 

There is not really a bug. Bugzilla helper needs better design. 

It is difficult to reproduce because the form data is usu cached. If the form
data becomes un-cached for whatever reason, the form is blank. 

If the field values are not cached, then this will happen (in every browser)
because the following:

* There is no client-side script on the to warn the user that he has not
selected a component, although there are alerts for missing description or title.

* The hosted program does not store the form data and then repopulate the form.

The browser not caching the form values may or may not be a bug. I don't even
consider it worth discussion here; it is merely acknowledged. 

The problem is that there is no catch when the form is not cached. Values from
the form data should be stored in the user's bugzilla session. Also, before the
form is submitted, there should be a simple alert or prompt to ask the user to
select a component.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
This turns out to have been a bug in Mozilla....

*** This bug has been marked as a duplicate of 179330 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Component: Creating/Changing Bugs → Layout: Form Controls
Product: Bugzilla → Browser
Resolution: --- → DUPLICATE
Version: 2.10 → Trunk
Making Bugzilla cope with this and deal with it more gracefully is covered on
bug 36843.
You need to log in before you can comment on or make changes to this bug.