Closed Bug 1717231 Opened 1 year ago Closed 1 year ago

Firefox 89 hangs (stops responding) in Instagram Stories

Categories

(Firefox :: General, defect)

Firefox 89
defect

Tracking

()

RESOLVED DUPLICATE of bug 1708224

People

(Reporter: i-svr, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

  1. Go to https://www.instagram.com/
  2. Login to your Instagram account
  3. Subscribe to some accounts, which post often (needed to have a number of "Stories" (these are short videos, which play one after another) to test the browser on them;
  4. Start watching Instagram Stories (click one of the "circles" on top of your Instagram feed);
  5. During watching some of those videos (maybe it'll be 5th video in a row, maybe 15th - there is no pattern), firefox will hang during playing next video and next video in feed won't play (there will be no sound of next video).

PS: this behavior started to occur since i updated firefox to version 89.0. I had no problem with Instagram whatsoever. Firefox 89 hanged in some other scenarios, but this scenario with "Instagram Stories" can be reproduced on my machine everyday with 100% reproducability. It hang every day for me since i updated to 89.0.

Actual results:

Firefox hangs during playing next video and next video in Instagram Stories feed won't play (there will be no sound of next video).
Firefox's window stops rendering anything (video stops, like if you pause it, but the sound plays, till this particular video's end; next video doesn't start playing), stops reacting to mouse clicking.
If you click on another program in panel and then switch back to Firefox, it's window will not be rendered.
One of my two CPU cores is loaded by 100% by firefox process, when it hangs.

Expected results:

Instagram Stories in Firefox should play one after another, without stopping, till the last one in feed gets played.
Firefox should not hang, should keep reacting to mouse clicks and be responsive.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Component: Widget: Gtk → General
Product: Core → Firefox

Hey i-svr,

Can you test the issue while in Safe Mode? You can find helpful info here : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode .
Also a fresh new profile could help. You can find more about creating a new profile here : https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems#w_6-create-a-new-firefox-profile .
If possible, you can test this issue on the nightly build as well. Download the build from : https://www.mozilla.org/en-US/firefox/nightly/all/ .

Flags: needinfo?(i-svr)

Sorry for the late response,
For several days I've been testing Firefox 89.0.2 release, which fixed following bug:

Fix occasional hangs with Software WebRender on Linux (bug 1708224)

And the problem is gone! This ticket can be closed.
Thank you.

Flags: needinfo?(i-svr)
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1708224
You need to log in before you can comment on or make changes to this bug.