Closed Bug 1717238 Opened 3 years ago Closed 3 years ago

Chat: Dialog persistence stopped working

Categories

(Thunderbird :: Instant Messaging, defect, P2)

Tracking

(thunderbird_esr78 wontfix)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- wontfix

People

(Reporter: thomas8, Assigned: freaktechnik)

References

(Regression)

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1717236 +++

Under meta bug 1585545, bug 1597964 converted some Chat dialogs so that their <dialog> element was no longer the root element. Unfortunately, the id was an important persistence attribute on the root element which should not have been moved to the <dialog> element.

This causes significant annoyance because even a dialog which you've just relocated to the right screen and position some seconds ago will stubbornly re-appear at its original position, which might be on the wrong screen. User feedback on Bug 1652290 about Spell Check dialogue shows the degree of user frustration.

See Bug 1698143 for how to fix this - the fix is simple, just needs good diligence.

This should be fixed as a matter of urgency.

See Also: → 1698143
Assignee: nobody → martin
Status: NEW → ASSIGNED
Target Milestone: --- → 91 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/7df12ccd0ac5
Move id of chat dialogs to windows. r=clokep

Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: