Closed Bug 1717385 Opened 1 year ago Closed 8 months ago

Folder pane scrolling is choppy and laggy using beta

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 90
Unspecified
macOS
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jph40108, Unassigned)

References

(Depends on 1 open bug, )

Details

(Keywords: perf)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.106 Safari/537.36

Steps to reproduce:

Hello. This bug is mostly a duplicate of bug 1697999 but I'm opening it because in TB 90.0b2 this is a real issue after upgrading from Mac OS Catalina to Big Sur. The only thing that changed was the OS upgrade, but now the folder pane has choppy, laggy scrolling, and when you click on a folder it is slow to respond. The problem seems isolated to the folder pane, other windows and buttons and scroll bars are fine.

I can't use TB at this point, and am limping along with Outlook, so I'm hoping this will get some attention.

Actual results:

Upgraded from Mac OS Catalina to Big Sur.

Expected results:

Folder pane should remain performant.

See Also: → 1697999

When using beta, does the scrolling performance improve if you disable webrender? set gfx.webrender.enabled false in config editor
And, specifically, what is your Mac model and graphics hardware?

ref bug 1692828 and bug 1676528

Component: Untriaged → General
Flags: needinfo?(jph40108)
Keywords: perf
OS: Unspecified → macOS

webrender is still a work in progress, and can negatively affect certain hardware. https://mzl.la/2UnVuBl lists some of these, and some non-webrender slowness.

There are several meta bugs https://mzl.la/2SNm4U1

Hi Wayne, thanks for your reply.

I checked gfx.webrender.enabled and it was already set to false. I tried setting it to true but no change. I also found some advice to check the "Reduce transparency" checkbox under System Preferences > Accessibility > Display, but there was also no change. I have a large number of folders.

My hardware is:
MacBook Pro (Retina, 15-inch, Late 2013)
Processor: 2.6 GHz Quad-Core Intel Core i7
Memory: 16 GB 1600 MHz DDR3
Graphics: NVIDIA GeForce GT 750M 2 GB

Are there any other settings worth trying?

Flags: needinfo?(jph40108)

I think now we wait to see what happens from bug Bug 1697999 comment 3

Depends on: 1697999
See Also: 1697999

OK, thank you. That sounds like it could take a little time. :-)

(In reply to Wayne Mery (:wsmwk) from comment #4)

I think now we wait to see what happens from bug Bug 1697999 comment 3

The details in bug 1697999 are currently not very promising. We may need to be patient

Component: General → Folder and Message Lists

Hello - just to report, I have downgraded today from TB 94.b05 to 92.2.1. As of 94.b04 and 05, this problem with choppy scrolling seems to have been fixed. When I downgraded, it's back, but definitely fixed in the later version, so thanks! (And to anyone reading this out of context, I downgraded due to issues in 94.b05).

(In reply to Josh from comment #7)

Hello - just to report, I have downgraded today from TB 94.b05 to 92.2.1. As of 94.b04 and 05, this problem with choppy scrolling seems to have been fixed. When I downgraded, it's back, but definitely fixed in the later version, so thanks! (And to anyone reading this out of context, I downgraded due to issues in 94.b05).

I think you mean 91.2.1?

You originally reported this issue when using beta 90. So it seems inconsistent that you would not see the problem when using 91.anything

Flags: needinfo?(jph40108)
Summary: Folder pane scrolling is choppy and laggy → Folder pane scrolling is choppy and laggy using beta
Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Flags: needinfo?(jph40108)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.