Closed Bug 1717429 Opened 3 years ago Closed 2 years ago

Bad contrast for the checkboxes of the "search in page" bottom toolbar on Linux with the default theme

Categories

(Toolkit :: Themes, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1783868
Accessibility Severity s3
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- affected
firefox89 --- unaffected
firefox90 --- wontfix
firefox91 --- wontfix
firefox92 --- wontfix
firefox93 --- fix-optional

People

(Reporter: julienw, Unassigned)

References

(Regression)

Details

(Keywords: access, regression)

Attachments

(2 files)

STR:

  • press ctrl + F on a web page

=> See how the contrast is especially bad on the checkboxes (see attachment).

This is better with the light theme, and much better with the dark theme.

Attachment #9228099 - Attachment description: Capture d’écran de 2021-06-21 14-55-02.png → Screenshot in Nightly 20210621094223

Compare with latest stable. Clearly something regressed in-between.

mozregression points to bug 1709601.

Regressed by: 1709601
Has Regression Range: --- → yes

Set release status flags based on info from the regressing bug 1709601

Is this the same as bug 1711030?

Flags: needinfo?(dao+bmo)
Component: Widget: Gtk → Themes
Product: Core → Toolkit

These checkboxes and their labels really look disabled.

I found that this line is causing this especially for the labels:
https://searchfox.org/mozilla-central/rev/c8ea016b87997574e1ca9127a4c370032aa6ee79/toolkit/themes/shared/findbar.css#183

Then there's the problem of the checkbox's border, that is probably more general and bug 1711030.

Keywords: access
Whiteboard: [access-s3]
Flags: needinfo?(dao+bmo)
Status: NEW → RESOLVED
Closed: 2 years ago
Duplicate of bug: 1783868
Resolution: --- → DUPLICATE
Accessibility Severity: --- → s3
Whiteboard: [access-s3]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: