Closed Bug 1717629 Opened 11 months ago Closed 4 hours ago

Intermittent netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should not have recorded key Allowed_SniffAsImageOrAudioOrVideo -

Categories

(Core :: Networking, defect, P2)

defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr78 --- unaffected
firefox89 --- unaffected
firefox90 --- unaffected
firefox91 --- wontfix
firefox99 --- disabled

People

(Reporter: intermittent-bug-filer, Assigned: edenchuang)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [retriggered][stockwell disabled][necko-triaged])

Attachments

(2 files)

Filed by: mlaza [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=343480018&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/AnDtKswtQRq8TN27CblzHg/runs/0/artifacts/public/logs/live_backing.log


[task 2021-06-22T13:32:50.718Z] 13:32:50     INFO - TEST-START | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js
[task 2021-06-22T13:32:53.705Z] 13:32:53     INFO - GECKO(1911) | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2021-06-22T13:32:53.708Z] 13:32:53     INFO - GECKO(1911) | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2021-06-22T13:33:10.975Z] 13:33:10     INFO - TEST-INFO | started process screentopng
[task 2021-06-22T13:33:11.241Z] 13:33:11     INFO - TEST-INFO | screentopng: exit 0
[task 2021-06-22T13:33:11.241Z] 13:33:11     INFO - Buffered messages logged at 13:32:50
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Entering test bound 
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Buffered messages logged at 13:32:52
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res.css.
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Buffered messages logged at 13:32:53
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Console message: [JavaScript Error: "Unknown Collection "main/partitioning-exempt-urls"" {file: "resource://services-settings/RemoteSettingsClient.jsm" line: 160}]
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - UnknownCollectionError@resource://services-settings/RemoteSettingsClient.jsm:160:5
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - sync@resource://services-settings/RemoteSettingsClient.jsm:475:13
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - 
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_SafeListed - 
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Buffered messages logged at 13:32:54
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res.csv.
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_BlockListedNeverSniffed - 
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Buffered messages logged at 13:32:55
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_206.html.
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_206AndBlockListed - 
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Buffered messages logged at 13:32:56
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_nosniff.html.
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_NosniffAndEitherBlockListedOrTextPlain - 
[task 2021-06-22T13:33:11.256Z] 13:33:11     INFO - Buffered messages logged at 13:32:57
[task 2021-06-22T13:33:11.257Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_img.png.
[task 2021-06-22T13:33:11.257Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.258Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2021-06-22T13:33:11.259Z] 13:33:11     INFO - Buffered messages logged at 13:32:58
[task 2021-06-22T13:33:11.260Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_nosniff2.html.
[task 2021-06-22T13:33:11.261Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.261Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_NoSniffHeaderAfterSniff - 
[task 2021-06-22T13:33:11.262Z] 13:33:11     INFO - Buffered messages logged at 13:32:59
[task 2021-06-22T13:33:11.262Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_not_ok.html.
[task 2021-06-22T13:33:11.263Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.263Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_ResponseNotOk - 
[task 2021-06-22T13:33:11.264Z] 13:33:11     INFO - Buffered messages logged at 13:33:00
[task 2021-06-22T13:33:11.264Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res.unknown.
[task 2021-06-22T13:33:11.265Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.265Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_FailtoGetMIMEType - 
[task 2021-06-22T13:33:11.266Z] 13:33:11     INFO - Buffered messages logged at 13:33:01
[task 2021-06-22T13:33:11.267Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_img_unknown.png.
[task 2021-06-22T13:33:11.268Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.269Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_ContentTypeBeginsWithImageOrVideoOrAudio - 
[task 2021-06-22T13:33:11.269Z] 13:33:11     INFO - Buffered messages logged at 13:33:02
[task 2021-06-22T13:33:11.270Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res.mp3.
[task 2021-06-22T13:33:11.271Z] 13:33:11     INFO - Console message: [JavaScript Warning: "Invalid URI. Load of media resource  failed." {file: "https://example.com/browser/netwerk/test/browser/dummy.html" line: 0}]
[task 2021-06-22T13:33:11.271Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.272Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2021-06-22T13:33:11.272Z] 13:33:11     INFO - Buffered messages logged at 13:33:03
[task 2021-06-22T13:33:11.273Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_206.mp3.
[task 2021-06-22T13:33:11.274Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.274Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2021-06-22T13:33:11.275Z] 13:33:11     INFO - Buffered messages logged at 13:33:04
[task 2021-06-22T13:33:11.276Z] 13:33:11     INFO - Console message: [JavaScript Warning: "Invalid URI. Load of media resource  failed." {file: "https://example.com/browser/netwerk/test/browser/dummy.html" line: 0}]
[task 2021-06-22T13:33:11.276Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_invalid_partial.mp3.
[task 2021-06-22T13:33:11.278Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.278Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_InvaliidPartialResponse - 
[task 2021-06-22T13:33:11.279Z] 13:33:11     INFO - Buffered messages logged at 13:33:05
[task 2021-06-22T13:33:11.280Z] 13:33:11     INFO - Console message: [JavaScript Warning: "Invalid URI. Load of media resource  failed." {file: "https://example.com/browser/netwerk/test/browser/dummy.html" line: 0}]
[task 2021-06-22T13:33:11.281Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_not_200or206.mp3.
[task 2021-06-22T13:33:11.282Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.282Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_Not200Or206 - 
[task 2021-06-22T13:33:11.283Z] 13:33:11     INFO - Buffered messages logged at 13:33:06
[task 2021-06-22T13:33:11.284Z] 13:33:11     INFO - Console message: [JavaScript Warning: "Invalid URI. Load of media resource  failed." {file: "https://example.com/browser/netwerk/test/browser/dummy.html" line: 0}]
[task 2021-06-22T13:33:11.285Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_img_for_unknown_decoder.
[task 2021-06-22T13:33:11.285Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.286Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2021-06-22T13:33:11.287Z] 13:33:11     INFO - Buffered messages logged at 13:33:07
[task 2021-06-22T13:33:11.288Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser//res_sub_document.html.
[task 2021-06-22T13:33:11.288Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.289Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should not have recorded key Allowed_NotImplementOrPass - 
[task 2021-06-22T13:33:11.289Z] 13:33:11     INFO - Buffered messages logged at 13:33:08
[task 2021-06-22T13:33:11.290Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_img.png.
[task 2021-06-22T13:33:11.291Z] 13:33:11     INFO - Buffered messages logged at 13:33:09
[task 2021-06-22T13:33:11.291Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.292Z] 13:33:11     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should not have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2021-06-22T13:33:11.292Z] 13:33:11     INFO - Buffered messages logged at 13:33:10
[task 2021-06-22T13:33:11.294Z] 13:33:11     INFO - Fetching cross-origin url: https://example.com/browser/netwerk/test/browser//res_object.html.
[task 2021-06-22T13:33:11.294Z] 13:33:11     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:11.295Z] 13:33:11     INFO - Buffered messages finished
[task 2021-06-22T13:33:11.296Z] 13:33:11     INFO - TEST-UNEXPECTED-FAIL | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should not have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2021-06-22T13:33:11.296Z] 13:33:11     INFO - Stack trace:
[task 2021-06-22T13:33:11.296Z] 13:33:11     INFO - chrome://mochikit/content/browser-test.js:test_ok:1331
[task 2021-06-22T13:33:11.296Z] 13:33:11     INFO - chrome://mochitests/content/browser/netwerk/test/browser/browser_opaque_response_blocking_telemetry.js:null:225
[task 2021-06-22T13:33:11.850Z] 13:33:11     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_img.png.
[task 2021-06-22T13:33:12.147Z] 13:33:12     INFO - Validating if the telemetry probe has been reported.
[task 2021-06-22T13:33:12.149Z] 13:33:12     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should not have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2021-06-22T13:33:12.151Z] 13:33:12     INFO - Leaving test bound 
[task 2021-06-22T13:33:12.222Z] 13:33:12     INFO - GECKO(1911) | MEMORY STAT | vsize 130551061MB | residentFast 1438MB
[task 2021-06-22T13:33:12.224Z] 13:33:12     INFO - TEST-OK | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | took 21505ms
[task 2021-06-22T13:33:12.288Z] 13:33:12     INFO - checking window state

Fixed frequent failure by backing out: https://bugzilla.mozilla.org/show_bug.cgi?id=1714299#c3

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Status: RESOLVED → REOPENED
Flags: needinfo?(echuang)
Resolution: FIXED → ---
Target Milestone: 91 Branch → ---
Assignee: nobody → echuang
Flags: needinfo?(echuang)

There are two problems needed to be fixed with the test.

  1. There are too many test cases in one subtests such that it could reach a timeout. This could be fixed by adding requestLongerTimeout()
  2. The assertion checking point for the request from <Object>/<Embed> is not correct. It seems not really to wait until the fetching response is ready.
Duplicate of this bug: 1717647
Has Regression Range: --- → yes

There are 91 total failures in the last 7 days on

[task 2022-02-24T13:48:32.807Z] 13:48:32     INFO - TEST-START | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js
[task 2022-02-24T13:48:39.736Z] 13:48:39     INFO - TEST-INFO | started process screencapture
[task 2022-02-24T13:48:39.859Z] 13:48:39     INFO - TEST-INFO | screencapture: exit 0
[task 2022-02-24T13:48:39.859Z] 13:48:39     INFO - Buffered messages logged at 13:48:32
[task 2022-02-24T13:48:39.860Z] 13:48:39     INFO - Entering test bound 
[task 2022-02-24T13:48:39.860Z] 13:48:39     INFO - Buffered messages logged at 13:48:33
[task 2022-02-24T13:48:39.861Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res.css.
[task 2022-02-24T13:48:39.862Z] 13:48:39     INFO - Console message: [JavaScript Error: "Unknown Collection "main/partitioning-exempt-urls"" {file: "resource://services-settings/RemoteSettingsClient.jsm" line: 158}]
[task 2022-02-24T13:48:39.862Z] 13:48:39     INFO - UnknownCollectionError@resource://services-settings/RemoteSettingsClient.jsm:158:5
[task 2022-02-24T13:48:39.862Z] 13:48:39     INFO - sync@resource://services-settings/RemoteSettingsClient.jsm:501:13
[task 2022-02-24T13:48:39.862Z] 13:48:39     INFO - 
[task 2022-02-24T13:48:39.862Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.863Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_SafeListed - 
[task 2022-02-24T13:48:39.863Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res.csv.
[task 2022-02-24T13:48:39.864Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.864Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_BlockListedNeverSniffed - 
[task 2022-02-24T13:48:39.865Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_206.html.
[task 2022-02-24T13:48:39.865Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.866Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_206AndBlockListed - 
[task 2022-02-24T13:48:39.866Z] 13:48:39     INFO - Buffered messages logged at 13:48:34
[task 2022-02-24T13:48:39.867Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_nosniff.html.
[task 2022-02-24T13:48:39.867Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.868Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_NosniffAndEitherBlockListedOrTextPlain - 
[task 2022-02-24T13:48:39.868Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_img.png.
[task 2022-02-24T13:48:39.869Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.869Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2022-02-24T13:48:39.870Z] 13:48:39     INFO - Buffered messages logged at 13:48:35
[task 2022-02-24T13:48:39.870Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_nosniff2.html.
[task 2022-02-24T13:48:39.871Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.871Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_NoSniffHeaderAfterSniff - 
[task 2022-02-24T13:48:39.872Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_not_ok.html.
[task 2022-02-24T13:48:39.872Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.873Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_ResponseNotOk - 
[task 2022-02-24T13:48:39.873Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res.unknown.
[task 2022-02-24T13:48:39.873Z] 13:48:39     INFO - Buffered messages logged at 13:48:36
[task 2022-02-24T13:48:39.874Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.874Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_FailtoGetMIMEType - 
[task 2022-02-24T13:48:39.875Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_img_unknown.png.
[task 2022-02-24T13:48:39.875Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.876Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_ContentTypeBeginsWithImageOrVideoOrAudio - 
[task 2022-02-24T13:48:39.876Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res.mp3.
[task 2022-02-24T13:48:39.877Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.877Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2022-02-24T13:48:39.878Z] 13:48:39     INFO - Console message: [JavaScript Warning: "Invalid URI. Load of media resource  failed." {file: "https://example.com/browser/netwerk/test/browser/dummy.html" line: 0}]
[task 2022-02-24T13:48:39.878Z] 13:48:39     INFO - Buffered messages logged at 13:48:37
[task 2022-02-24T13:48:39.879Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_206.mp3.
[task 2022-02-24T13:48:39.879Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.879Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2022-02-24T13:48:39.880Z] 13:48:39     INFO - Console message: [JavaScript Warning: "Invalid URI. Load of media resource  failed." {file: "https://example.com/browser/netwerk/test/browser/dummy.html" line: 0}]
[task 2022-02-24T13:48:39.880Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_invalid_partial.mp3.
[task 2022-02-24T13:48:39.881Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.881Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_InvaliidPartialResponse - 
[task 2022-02-24T13:48:39.882Z] 13:48:39     INFO - Console message: [JavaScript Warning: "Invalid URI. Load of media resource  failed." {file: "https://example.com/browser/netwerk/test/browser/dummy.html" line: 0}]
[task 2022-02-24T13:48:39.882Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_not_200or206.mp3.
[task 2022-02-24T13:48:39.883Z] 13:48:39     INFO - Buffered messages logged at 13:48:38
[task 2022-02-24T13:48:39.883Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.883Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Blocked_Not200Or206 - 
[task 2022-02-24T13:48:39.884Z] 13:48:39     INFO - Console message: [JavaScript Warning: "Invalid URI. Load of media resource  failed." {file: "https://example.com/browser/netwerk/test/browser/dummy.html" line: 0}]
[task 2022-02-24T13:48:39.884Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_img_for_unknown_decoder.
[task 2022-02-24T13:48:39.885Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.885Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2022-02-24T13:48:39.885Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser//res_sub_document.html.
[task 2022-02-24T13:48:39.886Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.886Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should not have recorded key Allowed_NotImplementOrPass - 
[task 2022-02-24T13:48:39.887Z] 13:48:39     INFO - Buffered messages logged at 13:48:39
[task 2022-02-24T13:48:39.887Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_img.png.
[task 2022-02-24T13:48:39.888Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.888Z] 13:48:39     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should not have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2022-02-24T13:48:39.889Z] 13:48:39     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser//res_object.html.
[task 2022-02-24T13:48:39.889Z] 13:48:39     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:39.889Z] 13:48:39     INFO - Buffered messages finished
[task 2022-02-24T13:48:39.890Z] 13:48:39     INFO - TEST-UNEXPECTED-FAIL | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should not have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2022-02-24T13:48:39.890Z] 13:48:39     INFO - Stack trace:
[task 2022-02-24T13:48:39.890Z] 13:48:39     INFO - chrome://mochikit/content/browser-test.js:test_ok:1394
[task 2022-02-24T13:48:39.890Z] 13:48:39     INFO - chrome://mochitests/content/browser/netwerk/test/browser/browser_opaque_response_blocking_telemetry.js:null:254
[task 2022-02-24T13:48:40.116Z] 13:48:40     INFO - Fetching cross-origin url: https://example.org/browser/netwerk/test/browser/res_img.png.
[task 2022-02-24T13:48:40.202Z] 13:48:40     INFO - Validating if the telemetry probe has been reported.
[task 2022-02-24T13:48:40.203Z] 13:48:40     INFO - TEST-PASS | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | Should not have recorded key Allowed_SniffAsImageOrAudioOrVideo - 
[task 2022-02-24T13:48:40.203Z] 13:48:40     INFO - Leaving test bound 
[task 2022-02-24T13:48:40.207Z] 13:48:40     INFO - GECKO(2815) | MEMORY STAT | vsize 16158MB | residentFast 408MB | heapAllocated 117MB
[task 2022-02-24T13:48:40.207Z] 13:48:40     INFO - TEST-OK | netwerk/test/browser/browser_opaque_response_blocking_telemetry.js | took 7400ms
[task 2022-02-24T13:48:40.216Z] 13:48:40     INFO - checking window state

Eden, are you still working on this?

Flags: needinfo?(echuang)

There is a patch waiting for review and landing, to solve the increasingly high frequency of failures caused after the landing of patch from Bug 1756696

(In reply to Natalia Csoregi [:nataliaCs] from comment #42)

There is a patch waiting for review and landing, to solve the increasingly high frequency of failures caused after the landing of patch from Bug 1756696

Eden, following up the discussion we had 2 days ago on Slack.
Has the patch fixing this been reviewed and ready to land? The pushlog issue has been fixed since.
Thank you!

Flags: needinfo?(echuang)
Flags: needinfo?(echuang)
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/57bff20874e7
disable browser_opaque_response_blocking_telemetry.js on opt platforms r=necko-reviewers,kershaw DONTBUILD
Attachment #9267362 - Attachment description: WIP: Bug 1717629 - disable browser_opaque_response_blocking_telemetry.js for all macOS versions → Bug 1717629 - disable browser_opaque_response_blocking_telemetry.js for all macOS versions
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/b062d05becb3
disable browser_opaque_response_blocking_telemetry.js for all macOS versions
Priority: -- → P2
Whiteboard: [stockwell disabled] → [retriggered][stockwell disabled][necko-triaged]

Opaque response blocking telemetry probes are expired.
browser_opaque_response_blocking_telemetry.js is also removed from mozilla-central.

Status: REOPENED → RESOLVED
Closed: 11 months ago4 hours ago
Flags: needinfo?(echuang)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.