Closed Bug 1717908 Opened 3 years ago Closed 1 year ago

Pausing feed account root folder no longer sets a property for reduced opacity UI feedback

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect

Tracking

(thunderbird_esr91 affected, thunderbird_esr102 wontfix, thunderbird90 wontfix, thunderbird91+ affected, thunderbird92 affected)

RESOLVED FIXED
114 Branch
Tracking Status
thunderbird_esr91 --- affected
thunderbird_esr102 --- wontfix
thunderbird90 --- wontfix
thunderbird91 + affected
thunderbird92 --- affected

People

(Reporter: alta88, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(3 files)

Both the account folder and all child folders should have reduced opacity. However, pausing individual folders does work correctly. Probably a regression from recent folderpane caching work.

Flags: needinfo?(alessandro)

Thanks for the report.
I'm not aware of this feature, sorry, could you give me some pointers for me to test it in 78 and daily so I can see the regression?
Cheers.

Flags: needinfo?(alessandro)

Set up a feed account, add a feed or two. Right click menu on the account item in folderpane, check pause all updates. Updates are turned off for all feeds in the account, and this is indicated by reduced opacity on the account and all subfolders with feeds.

This fixes the issue that the server never gets the disabled appearance.

But there is still the issue that the state isn't updated on change through the menu. I need to select the items again to let them know the actual status -> this is not a CSS issue.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9232820 - Flags: review?(alessandro)

Something probably about not setting/getting the folder cache property correctly or not invalidating the cell.

Sorry for the delay in reviewing this, I just got back from vacation :D.
I'll take a look at the caching implementation and see if I can solve the issue of the row not properly invalidating when required.

Comment on attachment 9232820 [details] [diff] [review]
1717908-feed-paused-style.patch

Review of attachment 9232820 [details] [diff] [review]:
-----------------------------------------------------------------

Good fix, but as you said not totally complete.
Let's keep this here until I find the culprit and then we can land everything together.
Attachment #9232820 - Flags: review?(alessandro) → feedback+

Alex, the Feeds needs some work to be like before the new tree implementation:

  • the feed favicon isn't shown
  • there is no busy indication when TB is checking for new entries (isBusy)
  • not sure if pausing is working but at least there is no icon indication (serverIsPaused, isPaused)
  • no indication when checking for updates is failing (hasError)
Flags: needinfo?(alessandro)

Favicon is bug 1824272.
Pausing most likely works, or at least it worked last time I worked on this code in bug 1789120.

See Also: → 1824272

Thanks for the analysis and info Richard.
Magnus, would you be able to take on this and bring the feed implementation to completion?

Flags: needinfo?(alessandro)

Sure, I'll take care of it.

Assignee: richard.marti → mkmelin+mozilla

I think we don't need the special server is paused.

Attachment #9331090 - Attachment description: Bug 1717908 - Fix feeds pausing/busy/error folder states. r=#thunderbird-front-end-reviewers → Bug 1717908 - Fix feeds pausing/busy/error folder states. r=Paenglab

(In reply to Magnus Melin [:mkmelin] from comment #12)

I think we don't need the special server is paused.

Is that related to pausing the feed account "in bulk" or the feeds individually?

Yes, it's paused/enabled for the account root folder. But it's the same as paused/enabled for individual feeds. (The property may have been needed for xul tree css rules(?))

Target Milestone: --- → 114 Branch
Attachment #9331090 - Attachment description: Bug 1717908 - Fix feeds pausing/busy/error folder states. r=Paenglab → Bug 1717908 - Fix feeds pausing/busy/error folder states. r=Paenglab,aleca

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/6058df549724
Fix feeds pausing/busy/error folder states. r=Paenglab,aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Reverts folderPane.changeFolderFlag to the previous version.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/d30c23444215
follow-up - Fix broken test browser_folderTreeQuirks.js. r=mkmelin
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: