Closed Bug 1718669 Opened 1 year ago Closed 1 year ago

Clicking "online banking" in becu.org does nothing with ETP set to STRICT

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Desktop
All
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox92 --- affected

People

(Reporter: eeejay, Unassigned)

References

(Blocks 1 open bug, )

Details

STR:

  1. Go to https://www.becu.org/
  2. Click the "ONLINE BANKING" link

Result:
Nothing happens

Expected:
Should go to login page.

Tested with nightly in "troubleshoot mode", works in Chrome.

i can't reproduce this with Firefox 89.0.1 and Nightly 91 using Linux.

What happens when you directly visit https://onlinebanking.becu.org/BECUBankingWeb/Login.aspx ? Is there any problem viewing the page? What Firefox version are you using? Have you tried a new profile?

Flags: needinfo?(eitan)

I narrowed the issue down to tracking protection. It works fine with tracking protection set to "standard" or off. But it doesn't work with tracking protection set to "strict".

Flags: needinfo?(eitan)

Needs Triage.

Flags: needinfo?(raul.bucata)
Flags: needinfo?(oana.arbuzov)

We appreciate your report. This is an Enhanced Tracking Protection, and will be moved to the correct Component and Product of this project. With Enhanced Tracking Protection set to STANDARD, the page loads.

Tested with:

Browser / Version: Firefox Nightly 92.0a1 (2021-07-20) (64-bit)
Operating System: Windows 10 PRO x64

Blocks: tp-breakage
Component: Desktop → Privacy: Anti-Tracking
Flags: needinfo?(raul.bucata)
Flags: needinfo?(oana.arbuzov)
OS: Unspecified → All
Priority: -- → P3
Product: Web Compatibility → Core
Hardware: Unspecified → Desktop
Summary: Clicking "online banking" in becu.org does nothing → Clicking "online banking" in becu.org does nothing with ETP set to STRICT
Severity: -- → S3

This seems to be working for me in Strict ETP and in a private browsing tab.

eeejay, does it still reproduce for you? Does anything appear in the devtools web console when you click the link?

Flags: needinfo?(eitan)

Ah, actually I see it now. I was having a conflict with some addons while testing. It looks like some analytics code is failing, which should be possible to fix with a SmartBlock shim.

Flags: needinfo?(eitan)

This link appears to be working now for me in the latest Firefox nightly build with ETP strict mode on, or in private browsing mode. Can you confirm if it works for you now as well, eeejay?

Flags: needinfo?(eitan)

Yes, it works. Thank you!

Flags: needinfo?(eitan)

Thomas, I can also confirm that this works as expected for me as well using the latest build of Firefox Nightly regardless of the status of ETP.

Tested with:

Browser / Version: Firefox Nightly 94.0a1 (2021-09-23) (64-bit)
Operating System: Windows 10 PRO x64

Thanks to both of you! Then let's close this as fixed for now, since the related shims have been updated a couple of times over the past few months.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.