Open Bug 1718750 Opened 1 year ago Updated 1 year ago

Reader Mode - Missing image after clicking on back and forward button

Categories

(Toolkit :: Reader Mode, defect, P3)

Firefox 90
defect

Tracking

()

Tracking Status
firefox-esr78 --- unaffected
firefox89 --- wontfix
firefox90 --- wontfix
firefox91 --- fix-optional

People

(Reporter: zstimi, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Affected versions

  • Fx 90.0b12
  • Fx 91.0a1

Affected platforms

  • Windows 8.1 x64
  • Windows 10 x64
  • Ubuntu 20.04 x64
  • macOS 11

Steps to reproduce

  1. Access the following webpage.
  2. Click on the Enter Reader View button from the Location bar.
  3. Navigate with Back/Forward buttons on the same tab where the reader view button was toggled.

Expected result

  • The Reader view functionality is not affected, the page looks the same, all the images are displayed.

Actual result

  • After click on back and forward buttons the images are missing from the page.

Regression range

Additional notes

  • This issue is reproduced only with certain pages.
  • Attached screenshot to illustrate the difference.
Has Regression Range: --- → yes
Has STR: --- → yes

Is this a regression from bug 1667145?

Flags: needinfo?(gijskruitbosch+bugs)

(In reply to Marco Castelluccio [:marco] from comment #1)

Is this a regression from bug 1667145?

Maybe, but it's unclear why that would have caused this issue, and it's now a 9-month old regression, and that change fixed other issues, so backing out isn't really an option. It's quite possible the source markup is different after moving in and out of reader mode... this would need someone to investigate further.

Flags: needinfo?(gijskruitbosch+bugs)
Regressed by: 1667145
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.