Closed Bug 1718755 Opened 2 years ago Closed 2 years ago

[Ubuntu] Customization footer buttons appear only after 1-2 seconds when switching from Dark to Alpenglow theme

Categories

(Core :: Widget: Gtk, defect)

Firefox 91
x86_64
Linux
defect

Tracking

()

VERIFIED FIXED
92 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox89 --- unaffected
firefox90 --- unaffected
firefox91 + wontfix
firefox92 --- verified
firefox93 --- verified

People

(Reporter: giorgia.moldovan, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(5 files)

Attached image Alpenglow.gif

Affected versions:

  • Nightly 91.0a1

Affected platforms:

  • Ubuntu 20.04.2 LTS

Unaffected platforms:

  • Windows 10x64
  • macOS 10.15

Steps to reproduce:

  1. Launch Firefox.
  2. Go to Customize toolbar (Hamburger menu → More tools → Customize toolbar).
  3. Select Dark theme from the list.
  4. Select Alpenglow theme.

Expected result:
Customization footer buttons are clearly visible.

Actual result:
Customization footer buttons appear only after 1-2 seconds after the Alpenglow theme is selected.

Regression range:

Additional notes
Screen cast attached to illustrate the issue.
The issue reproduces only when switching from Dark to Alpenglow theme.

Hi Emilio,

It seems that mozregression pointed out Bug 1717872 for causing this regression.

Can you please take a look?

Thanks!

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(emilio)
Flags: needinfo?(emilio)
Assignee: nobody → emilio
Status: NEW → ASSIGNED
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b6b225d4a81c
Use an early refresh driver runner rather than Dispatch() to coalesce theme changes. r=stransky

This allows us to remove the timeout (which was there for these prefs)
and makes the code a bit more explicit.

Unconditionally making all tests wait for rAF causes some timing changes
which cause some tests to time out / fail, see:

https://treeherder.mozilla.org/jobs?repo=try&revision=3aef4c168c6ab7d762dd360f49d4f56dff686c03

So this only does it when changing the prefs that care about it. Fix
some tests that were relying on the timeout to get this green.

Depends on D119023

Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6ad9e60bc38e
Use an early refresh driver runner rather than Dispatch() to coalesce theme changes. r=stransky
https://hg.mozilla.org/integration/autoland/rev/eae7bcfd58c9
Fix the SpecialPowers pref code to deal with ui / font prefs correctly after the previous change. r=kmag
Flags: needinfo?(emilio)

@emilio

could this failure be from this bug?

Otherwise after the previous change we might get some reftest failures
like this in noqr platforms if the snapshot is taken too soon:

https://treeherder.mozilla.org/jobs?repo=try&revision=5452076b8278fdb514e8c3bc10486b0c74917eb0

This patch fixes it.

Attachment #9230366 - Attachment description: Bug 1718755 - Ensure the reftest harness at least ticks the refresh driver once. r=tnikkel → Bug 1718755 - Ensure the reftest harness at least ticks the refresh driver once. r=tnikkel,mattwoodrow
Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3cc5fcf9aeb6
Use an early refresh driver runner rather than Dispatch() to coalesce theme changes. r=stransky
https://hg.mozilla.org/integration/autoland/rev/4566477a7075
Fix the SpecialPowers pref code to deal with ui / font prefs correctly after the previous change. r=kmag
https://hg.mozilla.org/integration/autoland/rev/babc4fdcd08c
Ensure the reftest harness at least ticks the refresh driver once. r=tnikkel
Pushed by mlaza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f2cc4fb3caa8
Follow-up: Put the rAF back in reftest-content.js. CLOSED TREE
Regressions: 1720485
Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9d579691527b
Use an early refresh driver runner rather than Dispatch() to coalesce theme changes. r=stransky
https://hg.mozilla.org/integration/autoland/rev/92e9abe2b2ad
Fix the SpecialPowers pref code to deal with ui / font prefs correctly after the previous change. r=kmag
https://hg.mozilla.org/integration/autoland/rev/12f268910571
Ensure the reftest harness at least ticks the refresh driver once. r=tnikkel
https://hg.mozilla.org/integration/autoland/rev/9ac290ec5884
Ensure global theme/font pref changes are handled regardless of the pres context being alive. r=jfkthame
Regressions: 1722480
Flags: qe-verify+

Managed to reproduce the issue on Nightly 2021-06-30 using Ubuntu 18.04 x64.
Retested everything on Firefox 92.0b2 and Nightly 93.0a1 using the same os. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.