Closed Bug 1718809 Opened 4 months ago Closed 4 months ago

Upgraded from Firefox 88 to 89.0.2 on Mac OS 11.4 and found some websites displaying blank pages

Categories

(Core :: Widget: Cocoa, defect)

Firefox 89
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: deanedridge, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

Went to this website:
https://docs.github.com/en/get-started/getting-started-with-git/caching-your-github-credentials-in-git

Went to this website:
https://docs.github.com

Went to this website:
https://app.pluralsight.com/player?name=f83ca95c-74e2-4a1d-8742-62b34ec47906&mode=live&clip=0&course=code-school-git-real&author=gregg-pollack

Actual results:

https://docs.github.com/en/get-started/getting-started-with-git/caching-your-github-credentials-in-git
Displays a white page. Other Github pages are fine.

https://docs.github.com
displays a blank white page.

https://app.pluralsight.com/player?name=f83ca95c-74e2-4a1d-8742-62b34ec47906&mode=live&clip=0&course=code-school-git-real&author=gregg-pollack
Displays a dark grey page.

Expected results:

Should have displayed the content on the screen.

More info:
I deleted the history, cache, cookies etc and problem still there.
I tried running Firefox in safe mode but problem still there.
I changed browser privacy from custom to standard, but problem still there.
I try home pages or subpages, and problem still there.

A funny thing happens when I refresh or load the page on the Github docs pages website: the content of the page splashes up on to the screen for a split second and then goes back to blank.

These two mentioned websites worked fine on Firefox 88.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Cocoa' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Widget: Cocoa
Product: Firefox → Core

I ended up doing a fresh install of Firefox 89.0.2 and the problem is no longer present.

The only reason I can think of for this original problem to happen is that some Firefox files got damaged when I downloaded Firefox 89.0.2 and went to install it without closing Firefox 88. I got a dialog box pop up and tell me to close Firefox, so I did, but perhaps the damage was already done. That is the only explanation I can come up with for this original problem to arise.

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.