Open Unrequested Windows blocker blocks existing window

VERIFIED DUPLICATE of bug 104470

Status

SeaMonkey
Preferences
VERIFIED DUPLICATE of bug 104470
16 years ago
12 years ago

People

(Reporter: Richard Körber, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
At the provided URL, the content is loaded by a

  window.open("someurl.html", "_top")

When "Open Unrequested Windows" is blocked, nothing will happen here. IMO this
is not desired, since no new window will be open by this action, but the
existing "_top" frame will be reused. This operation should be allowed even when
"Open Unrequested Windows" is forbidden.

The same should apply when window.open() addresses a window which has already
been opened before, by it's name. Since no new window will actually be opened by
this operation, the window.open() should be executed.

(I'm not sure if this is a bug or a request for enhancement, so I kept the
severity as normal.)

Comment 1

16 years ago
Browser, not engine ---> Prefs
Assignee: rogerl → ben
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Preferences
Ever confirmed: true
QA Contact: pschwartau → sairuh
This has been fixed for a while now.  Please always say what Mozilla build
you're using when filing a bug report!

*** This bug has been marked as a duplicate of 104470 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.