remove Exit from File menu and replace with Close

VERIFIED WONTFIX

Status

()

Firefox
Menus
VERIFIED WONTFIX
16 years ago
10 years ago

People

(Reporter: Marko Macek, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
see bug 65121

(I have an IE-using friend with a strong reflex to choose the last item in File
menu).

Comment 1

16 years ago
I've spoken with the module peers and this is not going to be fixed. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 2

16 years ago
What is being WONTFIX'ed in this bug? Is it the renaming of Exit to Close or the
behavior of not closing every opened window but only the current one?

I really think it's a problem that File > Exit closes every opened window. That
makes little sense in a normal Windows environment.

Comment 3

16 years ago
There already is a close window menu item on the file menu, so the bug isn't
about a behavior change.  It would be about removing the exit entry and moving
close to the bottom.

Comment 4

16 years ago
You are right! I didn't even notice the Close command because of the placement. 

Comment 5

16 years ago
The placement of "Close" between "Open" and "Save" is pretty standard
at least in the Mac environment.

Comment 6

16 years ago
It seems to me that most Windows apps have "Exit". MSIE has "Close", but MS
Paint, WordPad, Notepad, CD Player, Sound Recorder, Windows Media Player, the
Clipboard Viewer, and Imaging have "Exit". (All those programs have it at the
bottom of the File menu, and all of them have the menuitem close just that
window.) MS Office applications, with their strange pseudo-MDI interface, have
"Close" and "Exit" like Mozilla and Phoenix do.

Comment 7

15 years ago
If Firebird is tailored for the masses, this bug should certainly be fixed, imho.

Comment 8

15 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 9

15 years ago
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla
*** Bug 269877 has been marked as a duplicate of this bug. ***
*** Bug 326774 has been marked as a duplicate of this bug. ***

Updated

13 years ago
QA Contact: bugzilla → menus
*** Bug 349262 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 414205
Duplicate of this bug: 394116
You need to log in before you can comment on or make changes to this bug.