Install/Uninstall of old version 1.1 themes causes Mozilla to crash

RESOLVED DUPLICATE of bug 171931

Status

SeaMonkey
Themes
--
critical
RESOLVED DUPLICATE of bug 171931
15 years ago
9 years ago

People

(Reporter: Stefan, Assigned: shliang)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020930
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020930

I can download and install a new version 1.1 theme, but at the same moment as
Mozilla Software Installation displays success it crashes. Theme does not get
installed.

Trying to uninstall a version 1.1 Pinball theme causes Mozilla.exe to generate
an exception and crash. Mozilla crashes when I try to uninstall the old theme
through the themes dialog and Mozilla also crashes when I choose to uninstall
after trying to apply it through View|Apply Theme.


Reproducible: Always

Steps to Reproduce:
Install
1. Download a version 1.1 theme from Deskmod
2. Confirm download and installation

Uninstall
1. Edit|Preferences|Themes
2. Select version 1.1 theme to uninstall
3. Press Uninstall button
or
1. View|Apply Theme|<Theme name>
   Mozilla warns about old theme and gives option to uninstall by pressing OK
2. Press OK button

Actual Results:  
Install:
Mozilla crashes

Uninstall:
Mozilla crashes
or
Mozilla crashes

Expected Results:  
Install:
Prevent attempts to install a version <1.2 theme

Uninstall:
Old theme gets uninstalled
or
Old theme gets uninstalled

Comment 1

15 years ago
crash, severity -> critical
Severity: normal → critical
Keywords: crash

Comment 2

15 years ago
duping to bug 171931 and copying steps to reproduce.

*** This bug has been marked as a duplicate of 171931 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.