Sheets appear in wrong window

RESOLVED DUPLICATE of bug 168369

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 168369
16 years ago
16 years ago

People

(Reporter: Ian Eiloart, Assigned: saari (gone))

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
possibly related to: 170772

I have a toolbar bookmark with the URL above. If I have a text selection when I
select the bookmark, I get a google search on that text. 

Without a selection, I get popup sheet prompting me for the text to search. The
problem is that, sometimes, the sheet pops up on the wrong window - or even on a
new window. I think this may happen only AFTER a javascript has popped up a new
window. 

Furthermore, sometimes, the sheet gets left behind in a similar manner to bug 170772
(Reporter)

Comment 1

16 years ago
A quick way to reproduce this:

1. make a toolbar bookmark with the javascript url
2. visit <https://atlas.sussex.ac.uk/dev/atlas.php>
3. click on the button in that page - it will pop up a new window
4. select the toolbar bookmark that you made in step 1 - but in the new window.

The sheet which pops up will display in any open window except the one with focus.

Comment 2

16 years ago
Dup of bug 168369?
(Reporter)

Comment 3

16 years ago
Another symptom of this bug is that command-l places the focus on the wrong
window. For example, follow the sequence above omitting step 1. In step 4, hit
command-L this will place the focus on the first window that was opened, instead
of the current window.

Comment 4

16 years ago
Ian, that is definitely bug 168369.
(Reporter)

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 168369 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.