Keyboard weirdness when editing forms

VERIFIED INVALID

Status

()

VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: jbarham, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I'm using Phoenix to edit my Zope website through standard HTML forms
and after a while I start getting wrong values for the punctuation keys
(?, < etc.)

I don't think it's a bad keyboard or XP since if I close and restart
Phoenix it works fine and the problem doesn't appear in other Windows
apps running at the same time as the confused Phoenix.

Comment 1

16 years ago
Sounds like a Mozilla bug. Have you tested a recent mozilla nightly to see if
the bug is reproducible there?

Comment 2

16 years ago
Unable to reproduce this at all and I use web page forms all day long in
bugzilla and bonsai. 
(Reporter)

Comment 3

16 years ago
It happened again to me today, although it took much longer before it showed 
itself.

I also downloaded a nightly build of Mozilla yesterday and the problem has yet 
to manifest itself there.

Quite mysterious.  I don't think it's XP since I'm working on a fresh install.
(Reporter)

Comment 4

16 years ago
OK, Mozilla itself has just done it to me.

Exact symptons:
 - only SHIFTed punctuation/special keys appear to be affected.
 - what should be @#$%^ are output as, respectively, "/$%?
 - the {}:"<>? characters are also wrong (in some cases these have
   to be pressed twice to get something, as if I was pressing ALT-whatever)
(Reporter)

Comment 5

16 years ago
This is NOT a Mozilla bug since IE is exhibiting the same behaviour.

Curiously, though, it's not my keyboard since if I open up Notepad
all the keys work as expected.

Maybe some common underlying Windows control is at fault...

Apologies for the false alarm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
Mass-verifying of old bugs.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.