Closed Bug 1719739 Opened 1 year ago Closed 1 year ago

accounts api fails on subFolders

Categories

(Thunderbird :: Add-Ons: Extensions API, defect)

defect

Tracking

(thunderbird_esr78? fixed)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 ? fixed

People

(Reporter: TbSync, Assigned: TbSync)

Details

Attachments

(2 files, 1 obsolete file)

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.subFolders]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://messenger/content/parent/ext-mail.js :: traverseSubfolders :: line 1579" data: no] ext-mail.js

Attached patch bug1719739.patch (obsolete) — Splinter Review
Assignee: nobody → john
Attachment #9230354 - Attachment is obsolete: true

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/f963261bee8e
Prevent accounts API to fail on folders without subFolders. r=darktrojan

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

Comment on attachment 9230357 [details] [diff] [review]
bug1719739_esr78.patch

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Accounts API list method completely fails on TB78

Testing completed (on c-c, etc.):
Feedback from users is that the patch seems to fix the issue in TB78
https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=5c8b0b8125f8fbf40cc509f0e025ce20a53775d5

Risk to taking this patch (and alternatives if risky):
None.

Attachment #9230357 - Flags: approval-comm-esr78?

Comment on attachment 9230357 [details] [diff] [review]
bug1719739_esr78.patch

[Triage Comment]
Approved 78.12.0

Attachment #9230357 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.