Closed Bug 1719908 Opened 1 year ago Closed 1 year ago

All events and functions of the compose API, which give access to message content or allow to alter the message, should require the compose permission

Categories

(Thunderbird :: Add-Ons: Extensions API, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr78 wontfix, thunderbird91 fixed)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- wontfix
thunderbird91 --- fixed

People

(Reporter: TbSync, Assigned: TbSync)

Details

Attachments

(2 files)

The following functions/events can be used without any permission:

  • onAttachmentAdded
  • listAttachments
  • addAttachment
  • updateAttachment
  • removeAttachment

They should require the compose permission, like get/setComposeDetails.

Attachment #9230524 - Attachment description: Bug Bug 1719908 - Require compose permission for all events/function, which access or alter the message content. r=mkmelin. → Bug 1719908 - Require compose permission for all events/function, which access or alter the message content. r=mkmelin.
Attachment #9230524 - Attachment description: Bug 1719908 - Require compose permission for all events/function, which access or alter the message content. r=mkmelin. → Bug Bug 1719908 - Require compose permission for all events/function, which access or alter the message content. r=mkmelin.
Attachment #9230524 - Attachment description: Bug Bug 1719908 - Require compose permission for all events/function, which access or alter the message content. r=mkmelin. → Bug 1719908 - Require compose permission for all events/function, which access or alter the message content. r=mkmelin.
Attachment #9230524 - Attachment description: Bug 1719908 - Require compose permission for all events/function, which access or alter the message content. r=mkmelin. → Bug Bug 1719908 - Require compose permission for all events/function, which access or alter the message content. r=mkmelin.
Attachment #9230524 - Attachment description: Bug Bug 1719908 - Require compose permission for all events/function, which access or alter the message content. r=mkmelin. → Bug 1719908 - Require compose permission for all events/function, which access or alter the message content. r=mkmelin.
Status: NEW → ASSIGNED
Target Milestone: --- → 91 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/c5af306d06f4
Require compose permission for all events/function, which access or alter the message content. r=mkmelin.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/8de3c662979f
follow-up - Fix error message check for beta. r=john.bieling

Comment on attachment 9230881 [details]
Bug 1719908 follow-up - Fix error message check for beta. r=john.bieling

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Some tests fail.

Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):
None.

Attachment #9230881 - Flags: approval-comm-beta?

Comment on attachment 9230881 [details]
Bug 1719908 follow-up - Fix error message check for beta. r=john.bieling

[Triage Comment]
Approved for beta

Attachment #9230881 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.