Cancelling a creation of new bookmark folder still leaves a folder called New Folder

VERIFIED FIXED

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: André Dahlqvist, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
With current CVS of Phoenix, if I right-click on PT and choose New Folder and
hit Cancel a folder named "New Folder" will still appear on the PT. Blake says
the folder is created even before the properties dialog appears.

Comment 1

16 years ago
Confirmed with a recent linux build (this afternoon)

Updated

16 years ago
Summary: Cancelling a creation of new folder on PT still leaves a folder called New Folder → [Moz] Cancelling a creation of new folder on PT still leaves a folder called New Folder

Updated

16 years ago
Summary: [Moz] Cancelling a creation of new folder on PT still leaves a folder called New Folder → Cancelling a creation of new folder on PT still leaves a folder called New Folder

Comment 2

16 years ago
*** Bug 175942 has been marked as a duplicate of this bug. ***
Created attachment 112678 [details] [diff] [review]
patch to fix. 

If the user cancels the properties dialog (or clicks the X box), remove the
folder that was created.
Created attachment 112679 [details] [diff] [review]
oops, forgot a line
Attachment #112678 - Attachment is obsolete: true
(Reporter)

Comment 5

15 years ago
Thanks Ben. I tried this patch on top of current CVS and it worked as expected
(the folder New Folder is removed when you hit Cancel). I tried this on both the
PT and in Manage Bookmarks.
Summary: Cancelling a creation of new folder on PT still leaves a folder called New Folder → Cancelling a creation of new bookmark folder still leaves a folder called New Folder

Comment 6

15 years ago
cute!
A nit, I'd prefer to define a new function in BookmarksCommand:

openBookmarkProperties (aUrl)
{
  return
openDialog("chrome://browser/content/bookmarks/bookmarksProperties.xul", "",
"centerscreen,chrome,dependent,resizable=no", aUrl);  
}

and use it where it is needed to avoid to return in the openBookmark loop and
avoid js warnings.

Comment 7

15 years ago
s/and use/and to use
Created attachment 112708 [details] [diff] [review]
updated patch to address pch's comments
Attachment #112679 - Attachment is obsolete: true

Comment 9

15 years ago
fine!
for note: the "properties" case in openBookmark was for opening a property
dialog when ALT-clicking or ALT-ENTER. But it was not used anymore, you was
right to remove it since ALT saves for consistency. If we need it again, it's
easy to set it back.
-> me
Assignee: chanial → ben
fixed!
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 12

15 years ago
VERIFIED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030714
Mozilla Firebird/0.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.