Closed Bug 1720384 Opened 5 months ago Closed 5 months ago

Disabling Proton breaks Web Developer menu

Categories

(Firefox :: Menus, defect)

Firefox 90
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox90 --- affected
firefox91 --- unaffected
firefox92 --- unaffected

People

(Reporter: jcs, Unassigned)

Details

(Whiteboard: [proton-hamburger-menu])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:90.0) Gecko/20100101 Firefox/90.0

Steps to reproduce:

Disable Proton with browser.proton.enabled set to false.

Start Firefox 90, open the hamburger menu, click Web Developer.

Actual results:

A blank sub-menu appears.

Expected results:

The Web Developer menu should appear, or it should not open a sub-menu but just open the tools as it does with Proton enabled.

The Bugbug bot thinks this bug should belong to the 'Firefox::Menus' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Menus

I can also reproduce this on the latest Firefox Release 90, but can't reproduce it on Beta 91 nor Nightly 92.0a1 since the layout of the hamburger menu changed and Web Developer tools are displayed inside the More Tools submenu.
I am also not quite sure how backward compatibility should work for disabling Proton in the current Fx90.
Adding the appmenu whiteboard and confirming this issue so developers can look into this further.
Thanks for reporting!

Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [proton-hamburger-menu]

Per bug 1714841 comment 3

We're not fixing bugs with proton.enabled=false at this point.

given that this works in nightlies this is WORKSFORME.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.