[DOGFOOD] plaintext editor doesn't work

VERIFIED FIXED in M12

Status

()

Core
Editor
P1
critical
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Akkana Peck, Assigned: Charles Manske)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The plaintext editor is broken -- can't type anything in it.  It never gets any
OnEndDocumentLoad message.

Comment 1

19 years ago
This smells similar 16937, which was supposedly fixed.
(Reporter)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11
(Reporter)

Comment 2

19 years ago
The fix for that bug fixed the html editor (which was getting double loads), but
didn't help the plaintext editor (which is getting no loads at all).
(Reporter)

Updated

19 years ago
Assignee: akkana → cmanske
Status: ASSIGNED → NEW
(Reporter)

Comment 3

19 years ago
Reverting TextEditorAppShell.xul to version 1.29 at least partially fixes the
problem, so I'm passing this to Charley, who checked in 1.30.  1.30 was a change
to the window title; not clear to me why this should affect anything, but
apparently it does.  1.31 was a change by Kathy with the comment "fix plain text
editor", but it doesn't fix it at least on Linux.

Updated

19 years ago
Priority: P3 → P1
Summary: plaintext editor doesn't work → [DOGFOOD] plaintext editor doesn't work
Target Milestone: M11 → M12

Comment 4

19 years ago
submitting as a must fix for dogfood
(Assignee)

Comment 5

19 years ago
Akkana: Please close this if it now works OK on Linux.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

19 years ago
Yes, it's working now on Linux.  Thanks!

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 7

19 years ago
now the plain text editor doesn't even launch from the debug menu....

using 10/29 build.

see console....
(Reporter)

Comment 8

19 years ago
Oh, bummer!  It works in my debug Linux build.  Sujay, are there any error
messages printed to stdout?

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago

Comment 9

19 years ago
oh okay I'll file a separate bug for windows....it works for linux...

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
verified in 11/4 build.
You need to log in before you can comment on or make changes to this bug.