Closed Bug 172071 Opened 18 years ago Closed 18 years ago

enable URL's within text that do not have an "<a href=...></a>" tag

Categories

(SeaMonkey :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 10080

People

(Reporter: info, Assigned: asa)

Details

I often find myself cutting an pasting URL's from the content of a page where
the no html encoding has been applied.  Often this is in plain text environments
or in places where HTML encoding has been disabled (some forums operate in such
a fashion).

My suggestion would be to add a menu option to open in a new tab/window when
right clicking on text which appears to be a URL.  I believe Mail/News is
currently sensing the nature of a url ref within a plain text document.  This
would work differently in that it would not be appropriate to change the text to
appear as a URL as in Mail/News, however simply give the option open the
apparent url to reduce the steps involved in opening a new tab/window and then
cutting and pasting the URL over.
>right clicking on text which appears to be a URL.

The question is, how does Mozilla know what text is a URL and what isn't.
Is "slashdot.org" a URL?  What about local files?  

->enhancement
Severity: normal → enhancement
Mozilla currently does this in Mail/News.  If you create an e-mail with a URL in
it and send it without converting it to a link, Mozilla adds the <a href> tag to
the content:

<a class="moz-txt-link-freetext" href="http://www.url.com">http://www.url.com</a>

it might be possible to use the same alogrithm as what is currently be used in
Mail/News.

*** This bug has been marked as a duplicate of 10080 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.