Japanese text should be displayed in Japanese font even if lang attribute is invalid

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: kazhik, Assigned: shanjian)

Tracking

({intl})

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Japanese text should be displayed in Japanese font even if lang 
attribute is invalid.

Testcase:
http://bugzilla.mozilla.gr.jp/showattachment.cgi?attach_id=1201

Screenshot:
http://bugzilla.mozilla.gr.jp/showattachment.cgi?attach_id=1202 // Win98-J
http://bugzilla.mozilla.gr.jp/showattachment.cgi?attach_id=1203 // Win2k-J

Original report:
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=2231

Comment 1

16 years ago
It does, providing you specify a charset (EUC-JP for instance). Without a
charset, Mozilla can only make an educated guess, provided Auto-Detect is enabled.

Not providing a charset is a really, really bad idea.

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 2

16 years ago
Created attachment 101447 [details]
screen shot on 10-01 trunk build/WinME-JA

Koike-san:
Could you please try it on latest build? because it has been a while since the
original report.  Also it looks fine with me, notice I added a MS P Gothic item
based on your test case to make more clearly.

It shouldn't be related whether the document has charset meta-tag or not, as
far as turn on auto-detect, you should get proper display.

Updated

16 years ago
Attachment #101447 - Attachment mime type: text/html → image/jpeg
(Reporter)

Comment 3

16 years ago
Created attachment 101457 [details]
Screenshot(2002100208-trunk/Win98)

Comment 4

16 years ago
If ylong's screen shot is true for the current trunk build, I believe
the reporter is correct in saying that <lag=en> case does not use
Japanese fonts. 

I talked to Shanjian about this problem before. 
I believe we need to add another check to the current font
selection mechanism if we are not doing this already.

* When a lang attribute is set, try the font list of the encoding
  after we try the fonts list for the lang in the lang attribute.

Comment 5

16 years ago
In ylong's attachment in comment #2, the font used for the "en" case is
NsSim.
(Reporter)

Comment 6

16 years ago
*** Bug 148440 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

16 years ago
reassign it to myself. 
What kat is asking make sense, but it probably won't happen in near future. We
need to change the interface of fontmetrics to handle multiple lanugage groups.
Technically there is not big difficulty, the question is how much demand do we
have to justify the change. 
Assignee: yokoyama → shanjian
(Assignee)

Comment 8

16 years ago
accepting.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 9

16 years ago
I'mm not convinced that there's a need to change anything here for Mozilla.

The HTML is invalid. If a text is tagged in english and has content from the CJK
area, there's no way to know it's actually japanese and not chinese. 
It's up to the page author to correct his error if it's important that the right
font be selected.

Comment 10

14 years ago
Can't reproduce. 1.7.5/WinXP, Firefox 1.0/WinNT,Win98SE.
Please mark WORKSFORME.

Comment 11

14 years ago
There is a potential problem but such an occurrence seems to be rare and
probably not worth the effort to make changes in the code. Let's resolve this
bugs as Wontfix. 
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.