<td> html tag displaying with incorrect height

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P2
normal
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: csagaz, Unassigned)

Tracking

({regression, testcase})

Trunk
Future
x86
All
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(8 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
When I visiting the www.prog.hu page, the tittles were displayed with larger height
looks like a table layout issue..
Assignee: asa → karnaze
Component: Browser-General → HTMLTables
QA Contact: asa → amar

Comment 2

16 years ago
Please read the bug reporting guidelines. Which version do you use. What
*exactly* do you think is not correct, what *should* be displayed?

pi
(Reporter)

Comment 3

16 years ago
Here is the source line what displayed incorrect:
<td width="2" style="background-image: url(/images/wnd2right.gif)"><img
border="0" height="100%" width="2" src="/images/wnd2right.gif"></td>

This located at www.prog.hu main page

Mozilla 1.1 relaese version was displayed correctly but all version after it not.

I use this version:

Mozilla 1.2b

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021001

Comment 4

16 years ago
This shows up many times. The source of the page is really hard to read, so many
nested tables. What do you see and what do you think you should see? Maybe you
can make screenshots of the page as you see it in 1.2b and as you should see it.

Also note:
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.prog.hu%2F&charset=%28detect+automatically%29&doctype=Inline
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.prog.hu%2F&charset=%28detect+automatically%29&doctype=HTML+4.01+Transitional

This page fails badly. There are many missing closing tags in tables which might
cause various problem. Might be an evangelism bug.

pi
(Reporter)

Comment 5

16 years ago
Created attachment 101537 [details]
I see it with Mozilla1.2b
(Reporter)

Comment 6

16 years ago
Created attachment 101538 [details]
And I see it with IExplorer and Mozilla 1.1 release

Comment 7

16 years ago
Created attachment 101607 [details]
Testcase

Comment 8

16 years ago
Try Shift-Reload and/or Reload the testcase a few times and observe the two
tables behaves differently (sometimes Table 2 looks OK).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows 98 → All

Comment 9

16 years ago
Bug occurs with 2002-09-23-08 trunk Linux
Bug occurs with 2002-10-02-08 trunk Linux

I have a local build from a mid-August checkout where this bug
does not occur. I suspected bug 154780 at first but after
applying the two patches there the bug still did not occur.
Keywords: regression
(Reporter)

Comment 10

16 years ago
Created attachment 101664 [details]
It was occured when a I pressed shift+reload

Your testcase page was displayed correctly with shift+reload, but You have one
table and prog.hu has got many tables.

Comment 11

16 years ago
OK, now I see what the reporter meant. I don't understand the testcase, though.
The tr element does not have a height attribute:
http://validator.w3.org/check?uri=http%3A%2F%2Fbugzilla.mozilla.org%2Fattachment.cgi%3Fid%3D101607%26action%3Dview&charset=iso-8859-2+%28Central+Europe%29&doctype=HTML+4.01+Transitional

What I see in the testcase (Linux latest-trunk): In both table1 and table2 the
Row 1 has the same height. The width of the columns differ, but I think this is
not what this bug is about.

pi
Created attachment 101678 [details]
Screenshot of testcase on Linux

Comment 13

16 years ago
Created attachment 101679 [details]
Another Linux screenshot of testcase

This is how it looks to me. After Shift-Reload it looks like the previous
screenshot.

pi
(Reporter)

Comment 14

16 years ago
Created attachment 101681 [details]
testcase with simple reload
(Reporter)

Comment 15

16 years ago
Created attachment 101682 [details]
testcase with shift+reload

Comment 16

16 years ago
Created attachment 101683 [details]
Testcase in valid HTML

Making the testcase valid does not change the output.

pi
Attachment #101607 - Attachment is obsolete: true

Updated

16 years ago
Priority: -- → P2
Bulk setting karnaze's P2-P5 bugs to future
Target Milestone: --- → Future

Comment 18

15 years ago
mass reassign to default owner
Assignee: karnaze → table
QA Contact: amar → madhur
Target Milestone: Future → ---

Updated

15 years ago
Target Milestone: --- → Future
WFM, 2003-06-03-05 trunk Linux

Comment 20

15 years ago
This bug worksforme with Windows Seamonkey builds 2004020909
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.