components directory created with wrong permissions

VERIFIED DUPLICATE of bug 163524

Status

SeaMonkey
Installer
VERIFIED DUPLICATE of bug 163524
16 years ago
13 years ago

People

(Reporter: Ralph Hartley, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The mozilla/components directory is created with permisions rw-rw-r-- but it
should be rwxr-xr-x.

If the intallation is not being run as root, it will fail, presumably because of
lack of execute permision on the directory.

This could depend on system/user defaults, but all other directories seem to get
the right permisions.

Build ID: 2002091016 mozilla-i686-pc-linux-gnu-1.2a-sea.tar.gz

Workaround: create mozilla/components with the correct permisions before installing.

Updated

16 years ago
QA Contact: bugzilla → ktrina

Comment 1

16 years ago
dupe of "installer creates components directory without exec perm"

*** This bug has been marked as a duplicate of 163524 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified as a dupe of bug 163524. Thank you Andrew!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.