Closed Bug 1721453 Opened 1 year ago Closed 1 year ago

Wayland Crash with "Lost connection to Wayland compositor."

Categories

(Core :: Widget: Gtk, defect, P1)

Firefox 90
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jimbo2150, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:90.0) Gecko/20100101 Firefox/90.0

Steps to reproduce:

Open Firefox
Browse Internet
Open new tab and enter URL (or drag/drop link to open new tab)
Firefox begins to load page then freezes for a few seconds

Actual results:

After doing reproduction steps, Firefox will either recover or crash with the console message (no crash report created):

Gdk-Message: 14:26:00.751: Lost connection to Wayland compositor.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.
Exiting due to channel error.

Note: The crash occurs in webrender software (default) or hardware mode.

Expected results:

Not crash. Issue does not happen in X11.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Please attach your about:support page.
Thanks.

Blocks: wayland
Flags: needinfo?(jimbo2150)
Priority: -- → P1
Attached file support.txt

I was not able to get it to happen in software mode again after the first (not sure if something else had been enabled - maybe a test? - that got disabled after.

Attached is my current about:support. I was able to stop the crashes by setting widget.wayland.vsync.enabled = false.

Flags: needinfo?(jimbo2150)

It seems to happen less often when scaling is lower. I lowered the screen scaling from 120% to 110% and it has yet to crash. I'm also seeing a lot fewer ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost console messages.

Looks like it may be a driver issue. I installed the latest intel-media-va-driver 21.2.2 (vs the 21.1.1 that comes with Ubuntu 21.04) and so far there has been no crashes (even with widget.wayland.vsync.enabled set to true). I have a Tiger Lake GPU so I assume that the newer driver has better support for the newer hardware.

Prior to installing the latest driver version I noticed that the 21.1.1 non-free Intel driver is more stable than the 21.1.1 free driver.

There are still odd few-second freeze-ups when doing certain things like opening bookmark folders in the bar or hovering over tabs (prior to the tooltip displaying)... but that may be a separate issue (it is largely what happens prior to the crashes happening).

(In reply to Jim from comment #5)

Looks like it may be a driver issue. I installed the latest intel-media-va-driver 21.2.2 (vs the 21.1.1 that comes with Ubuntu 21.04) and so far there has been no crashes (even with widget.wayland.vsync.enabled set to true). I have a Tiger Lake GPU so I assume that the newer driver has better support for the newer hardware.

Prior to installing the latest driver version I noticed that the 21.1.1 non-free Intel driver is more stable than the 21.1.1 free driver.

Okay, let's close this one then.

There are still odd few-second freeze-ups when doing certain things like opening bookmark folders in the bar or hovering over tabs (prior to the tooltip displaying)... but that may be a separate issue (it is largely what happens prior to the crashes happening).

Please try to get profile data (see https://profiler.firefox.com/) i.e. run profiler when Firefox freezes and file a new bug for it and attach the profile data there.

Thanks.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME

I'm afraid this isn't resolved, still a problem

Attached video recording.m4v

Recording of the crash with sway 1.6.1 and today's daily 93.0a1hg20210810r588305-0ubuntu0.21.04.1~umd1

(In reply to luis.pabon from comment #7)

I'm afraid this isn't resolved, still a problem

Please file a new bug for, run firefox with WAYLAND_DEBUG=1 and attach the log there. It may be Sway specific one.
Thanks.

Roger that 👍

You need to log in before you can comment on or make changes to this bug.