Closed Bug 1721476 Opened 2 months ago Closed 2 months ago

sqlite 3.34 changed it's open semantics, causing nss failures.

Categories

(NSS :: Libraries, defect)

3.67
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rrelyea, Assigned: rrelyea)

References

Details

Attachments

(2 files)

https://sqlite.org/forum/info/42cf8e985bb051a2

sqlite is now permissive on opening a readonly file even if you ask for the file to be opened R/W.

normally sqlite is very conservative in changing it's underlying semantics, but evidently they chose convience over compatibility. NSS now needs to check the file permissions itself to preserve nss semantics.

The attached patch is for reference I'll attach a phabricator version for review.

This should be the last of the rebase patches. I missed this one originally because it was only in fedora and rhel-9. It's not critical until more people start using nss with sqlite 3.44.

Assignee: nobody → rrelyea
Status: NEW → ASSIGNED
Severity: -- → S3

https://sqlite.org/forum/info/42cf8e985bb051a2

sqlite is now permissive on opening a readonly file even if you ask for the file to be opened R/W.

normally sqlite is very conservative in changing it's underlying semantics, but evidently they chose convience over compatibility. NSS now needs to check the file permissions itself to preserve nss semantics.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 3.69
See Also: → 1714874
Duplicate of this bug: 1690232
You need to log in before you can comment on or make changes to this bug.