Closed Bug 1721585 Opened 1 year ago Closed 1 year ago

The tooltip for the Reader mode icon in the url bar sometimes displays "undefined"

Categories

(Toolkit :: Reader Mode, defect, P1)

Desktop
All
defect
Points:
1

Tracking

()

VERIFIED FIXED
93 Branch
Iteration:
93.1 - Aug 9 - Aug 22
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- verified
firefox90 --- wontfix
firefox91 --- wontfix
firefox92 + verified
firefox93 --- verified

People

(Reporter: pascalc, Assigned: bugzilla)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot of the bug

Mozilla/5.0 (X11; Linux x86_64; rv:92.0) Gecko/20100101 Firefox/92.0 ID:20210720215601

STR:
1/ put your pointer on the reader mode icon in the url bar, repeat it several times

ER:
A tooltip with an explanation of what the icon is for is displayed

AR:
Once in a while, instead of the description, the value "undefined" is displayed instead

See attached screenshot.

Ubuntu 21.04, French build.

The Bugbug bot thinks this bug should belong to the 'Toolkit::Reader Mode' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Reader Mode
Product: Firefox → Toolkit
Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression
OS: Unspecified → All
Regressed by: 1706479
Hardware: Unspecified → Desktop

Set release status flags based on info from the regressing bug 1706479

Requesting needinfo as this was marked as regressed by bug 1706479.

Flags: needinfo?(htwyford)

I can't seem to reproduce the issue. It's interesting that this is intermittent. I fixed a similar issue that was permanent in bug 1712569.

[Tracking Requested - why for this release]:
Minor UI regression. Requesting tracking so I don't forget to fix it :)

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Flags: needinfo?(htwyford)
Severity: -- → S4
Priority: -- → P1
Iteration: --- → 93.1 - Aug 9 - Aug 22
Points: --- → 1

The bug was that the tooltip was only being shown for reader-mode-button-icon. The tooltip would show if you hovered right over the icon, and it would be undefined otherwise. This patch shows the tooltip regardless of the hover target. The other items on nodeToTooltipMap and nodeToShortcutMap are toolbarbuttons, so their icons are added in CSS and event handling always sees the parent node as the hover target. The reader mode button icon, however, is an <image> child of its parent. Either it or its parent could be hover targets. I considered added some handling in GetDynamicShortcutTooltipText along the lines of checking hg up centralnode.closest(reader-mode-button). I settled on just adding more entries to nodeToTooltipMap and nodeToShortcutMap since it's safer and easier to uplift.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ad36c1999df
Show tooltip for both reader-mode-button and reader-mode-button-icon. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(htwyford)

Comment on attachment 9235417 [details]
Bug 1721585 - Show tooltip for both reader-mode-button and reader-mode-button-icon. r?jaws!

Beta/Release Uplift Approval Request

  • User impact if declined: Minor UI regression where a tooltip will read "undefined".
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Well-understood, and the fix is very narrowly scoped.
  • String changes made/needed:
Flags: needinfo?(htwyford)
Attachment #9235417 - Flags: approval-mozilla-beta?

Comment on attachment 9235417 [details]
Bug 1721585 - Show tooltip for both reader-mode-button and reader-mode-button-icon. r?jaws!

Approved for 92.0b3 and 91.1esr.

Attachment #9235417 - Flags: approval-mozilla-esr91+
Attachment #9235417 - Flags: approval-mozilla-beta?
Attachment #9235417 - Flags: approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Verified as fixed on Windows 10 x64, macOS 11.4 and on Ubuntu 20.04.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.