Closed Bug 1721678 Opened 2 months ago Closed 2 months ago

update in background

Categories

(Toolkit :: Application Update, defect)

Firefox 90
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1651133

People

(Reporter: glennmcc, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:90.0) Gecko/20100101 Firefox/90.0

Steps to reproduce:

Attempted to open a link in new tab

Actual results:

Sorry. We just need to do one small thing to keep going.

Firefox has just been updated in the background. Click Restart Firefox to complete the update.

We will restore all your pages, windows and tabs afterwards, so you can be on your way quickly.

Expected results:

The link should have opened but instead got the message that FF was updated.

Why does this keep happening even-tho I'm already running the latest version of 90.0.1 ?

Hi Glenn,

Firefox will always update to the latest version when available, and at the moment the latest release version is 90.0.2.
Some updates require a browser restart in order to take place.

Yeah but.... that does not explain why the latest/greatest version for-which
no updates are available keeps popping-up the updated in background, restart required message.

Just now happened yet again with Firefox v90.0.2 which I just upgraded earlier today from v90.0.1

Here's a screenshot showing the 'updated in background/restart needed along with 'about firefox' showing that it did indeed happen
on a brand-new v90.0.2 for-which no updates are available.

http://glennmcc.org/images/update_in_background_BUG.png

THAT my good sirs & madams IS a very irritating BUG !

The Bugbug bot thinks this bug should belong to the 'Toolkit::Application Update' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Application Update
Product: Firefox → Toolkit

It looks like you are using Linux. Do you have a package manager that is configured to install updates for Firefox?

Flags: needinfo?(glennmcc)

Yes, I do.

This is Slackware64-current

And what's now installed is....

+--------------------------+
Thu Jul 22 19:23:58 UTC 2021
xap/mozilla-firefox-90.0.2-x86_64-1.txz: Upgraded.
This is a bugfix release.
For more information, see:
https://www.mozilla.org/en-US/firefox/90.0.2/releasenotes/


That is indeed the most recent release of Firefox for-which no updates exist.
https://www.mozilla.org/en-US/firefox/releases/

The 'updated in background/restart needed' is still happening from time-to-time.
This began with v90.0.2 just a couple of hours after installing it.

BTW, this has been happening with several versions of firefox.

IIRC, first saw it in v88.

Flags: needinfo?(glennmcc)

This is a known problem that we are working on a solution for.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1705217

This is not a duplication.

This is NOT happening as a result of upgrading via slackpkg package manager while firefox is running
because firefox is NOT running when I do my upgrades.

I always run slackpkg directly at the Linux console cli while nothing else is running.

And the 'updated in background/restart needed' does not happen only immediately
after an upgrade to a new release of firefox but rather continues to happen time-after-time.

This is a problem which has existed for serveral releases of firefox and a search on the web turns-up
quite a few 'fixes' that are supposed to stop it from happening.

https://www.google.com/search?q=stop+firefox+update+in+background

I have tried every one of the suggested fixes and none of them work.

Here's a suggestion for FireFox v91

Please bring back the option which existed in previous releases so that we can completely disable the checking for updates.

Here's what existed in FireFox v52.9.0
which I still use on one of my other computers because flashplayer is needed for viewing both of my older security cameras.

http://glennmcc.org/images/never-check-for-updates.png

Just found another 'fix' that I had not yet tried.

https://winaero.com/how-to-disable-firefox-background-updates/#On_Linux

The policies.json I tried which did not work was...

{
"policies": {
"DisableAppUpdate": true
}
}

Now trying.....

{
"policies":
{
"BackgroundAppUpdate": false
}
}

Status: RESOLVED → UNCONFIRMED
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Resolution: DUPLICATE → ---

Please bring back the option which existed in previous releases so that we can completely disable the checking for updates.

That does exist in the form of an enterprise policy, DisableAppUpdate. It looks like you've already discovered it.

Now trying.....

{
"policies":
{
"BackgroundAppUpdate": false
}
}

This will not help you. Background update is currently a Windows-only feature, so disabling it on Linux won't do anything.


It sounds like you are pretty confident that Firefox is updating you rather than the package manager. Is this because Firefox is updating when you do not expect it to? Are you seeing anything else to confirm this?

Could you also please gather some more information for me? Please navigate to the Settings page (about:preferences) and find the "Update" section. Click on the "Show Update History" button. What time was the most recent update installed? Does this approximately match with the last time you saw a "Restart Required" page?

I KNOW an an absolute certainty that my package manger is not doing the update
because slackpkg is run manually ONLY when I choose to do updates.

The screenshot at http://glennmcc.org/images/update_in_background_BUG.png
shows proof that firfeox itself diplayed the message that an update in background had been done
and a restart was needed BUT no such update was actually done because NO updates are available.

As to about:preferences ...

There is NO section for updates on that page in v90.0.2

That section did exist in v52.9.0 on my other computer,
but it's gone from v90.0.2 and quite a few versions before that.

It just happened yet again attempting to go to about:preferences

http://glennmcc.org/images/update_in_background_BUG-yet-again.png

After the restart... we see that there is no "Show Update History" button on the about:preferences page.

http://glennmcc.org/images/updates.png

As this screenshot shows, that button was there in v52.9.0

http://glennmcc.org/images/never-check-for-updates.png

(In reply to Glenn McCorkle from comment #12)

The screenshot at http://glennmcc.org/images/update_in_background_BUG.png
shows proof that firfeox itself diplayed the message that an update in background had been done
and a restart was needed BUT no such update was actually done because NO updates are available.

That message does not mean that Firefox updated itself. It means that the version of Firefox on the hard drive does not match the version of Firefox in memory (the version that is currently running). This prevents it from being able to start new processes properly. We are working on a fix for this, but it may be some time before it is complete.

As to about:preferences ...

There is NO section for updates on that page in v90.0.2

If there is nothing in the "Updates" section on that page, it means that your copy of Firefox was built without support for self-updating. Therefore, it should not be possible that your copy of Firefox is updating itself. If you feel that you have reason to believe otherwise, I can help you look into it further. But at the moment, all the evidence points to updates coming from elsewhere.

I've never heard of this, but it could be technically possible that you are seeing the "Restart Required" message erroneously. You could check the version number before and after restarting to see if an update has actually happened. You should probably check the full build ID, since the version number may not change on every update. You can find these values on the first few lines of about:support. I believe that you ought to be able to open this page even if you are already getting the "Restart Required" message.

Attached file about:support
re:"That message does not mean that Firefox updated itself. It means that the version of Firefox on the hard drive does not match the version of Firefox in memory (the version that is currently running)"

Your are mistaken in that assumption.

The only version in memory is the version I fired-up which is v90.0.2
and there are no updates available for it.

Therefore the message that it was updated is a bug because it could not get updated.

re:"If there is nothing in the "Updates" section on that page, it means that your copy of Firefox was built without support for self-updating. Therefore, it should not be possible that your copy of Firefox is updating itself. "

Since it's not possible for this build firefox to update itself... why does it keep saying that it did update itself ???

about:support shows....

(In reply to Glenn McCorkle from comment #16)

Therefore the message that it was updated is a bug because it could not get
updated.

I would like for you to check the version and build ID in about:support before and after restarting before we make the assumption that no update has been installed. If neither change after the restart, then I agree that there is a problem.

why does it keep saying that it did update itself ???

From your screenshot:

Firefox has just been updated in the background.

It does not say that it updated itself; it simply says that it has been updated. And until you check that the version and build ID do not change after restarting, the most likely explanation is that it has indeed been updated.

I'm sorry that this does not seem to be the answer that you want. I am trying my best to help you here. I would appreciate some patience while we investigate your problem together.

re:" I've never heard of this, but it could be technically possible that you are seeing the "Restart Required" message erroneously."

That is exactly the point I have been trying to get across.

It is happening erroneously because there is nothing else on this Slackware Linux system which can do an update to firefox in the background.

It can only be updated via removing the firefox version currently installed and installing different version
using the package manager called "slackpkg" which is run manually via this command at the Linux console cli

slackpkg upgrade firefox

That process removes ALL of the currently installed version from the hard drive and installs the new one to the hard drive.

Here we go.... THIS is that process.

http://glennmcc.org/images/update-firefox-with-slackpkg.webm

Used slackpkg to remove firefox v90.02 and install v68.12.0esr from the slackware64-14.2 repository.

Then used slackpkg to remove v68.12.0esr and install v90.0.2 from the slackware64-current repository.

Alright... let's have a look at about:support on my 3rd computer running Windows10

This is a fresh install of firefox v90.0.2 downloaded and installed from mozilla.org

Application Basics

Name: Firefox
Version: 90.0.2
Build ID: 20210721174149
Distribution ID:
Update Channel: release
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0
OS: Windows_NT 10.0 19043


Application Basics

Name: Firefox
Version: 90.0.2
Build ID: 20210722130430
Distribution ID:
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:90.0) Gecko/20100101 Firefox/90.0
OS: Linux 5.13.6 #1 SMP Wed Jul 28 15:05:58 CDT 2021


As we see, the brand new install for Windows was built a day before the build I have for Linux.

It looks like this bug may describe the problem that you are having. If so, it looks like that problem should be fixed in version 91. If not, let me know and we can keep investigating.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1651133

Not exactly the same as the problem I'm here in v90.0.2 but quite similar.

When the upgrade from 90.0.2 to 91.x takes place, will let you know if it still happens.

Thanks for at-least trying to help. :)

OK, that's the last straw.

It happened twice more in just the past hour. :(

I'm now reverting back to v68.12.0esr til v91 is released.

So-far-so-good....
Have upgraded to v91.0 and now to v91.0.1 and have not as-yet been nagged with the 'updated in background, restart required' screen.

Well... the bug seems to be fixed and that message is now only being displayed when it actually SHOULD be.
It just popped-up a few min ago due the fact that I did indeed update firefox via slackpkg while it was running
therefore, the copy in memory was the previous version and thew copy on HDD is the updated version.

Mon Aug 23 20:05:36 UTC 2021
xap/mozilla-firefox-91.0.1-x86_64-2.txz: Rebuilt.
Rebuilt with: --with-unsigned-addon-scopes=app,system --allow-addon-sideload

You need to log in before you can comment on or make changes to this bug.