Closed Bug 172172 Opened 17 years ago Closed 16 years ago

Mac OSX only - hang 100% CPU with Flash

Categories

(Core :: Plug-ins, defect, P3)

PowerPC
macOS
defect

Tracking

()

VERIFIED WORKSFORME
mozilla1.4beta

People

(Reporter: peterlubczynski-bugs, Assigned: peterl-bugs)

References

()

Details

(Keywords: hang, Whiteboard: [PL2:NA])

Attachments

(1 file)

This is the Mac version of bug 132759. We hang on http://www.overclockmaniak.com
while Mac IE does not.
Does Chimera also hang?
OS: Windows XP → MacOS X
Chimera seems to work a little better but not much on my slow 400 Mhz. I see
lots of spinning wheels.
*** Bug 172175 has been marked as a duplicate of this bug. ***
*** Bug 174569 has been marked as a duplicate of this bug. ***
The patch for bug 132759 

http://bugzilla.mozilla.org/attachment.cgi?id=100352&action=view

does alot of stuff in #ifndef XP_MAC blocks.  Does this affect OS9 too?
Keywords: hang
Priority: -- → P3
Whiteboard: [PL2:NA]
Target Milestone: --- → mozilla1.4beta
this URL gets down both Chimera and Mozilla 1.x:

http://www.macromedia.com/desdev/mx/flash/articles/flash_3d_5.0.html

the browser just hangs. can't close it. have to force quit it.

also flash content in multiple browser windows makes the browsers slower and
slower...
That flash animation works fine for me. What Shockwave plugin version do you
have? It may be on slower machine that it slows things down too much.
i have the latest version: 6r47.
i also tested the latest beta of the plugin.

this does not happen in IE. so it seems a mozilla/chimera problem.

i have no slow machine. it's a powerbook DVI 667 with 1GB ram running OS X 10.2.2.
dup of bug 106397?
http://www.x-men-the-movie.com/

Click on any language (I use "English"), let the popup window load, then try
navigating in Cerebro. No luck. Get the spinning beachball and a hang.

Bummer.

This bug seems to affect Flash plug-ins that take up the entire browser content
window. Small Flash movies, like in advertisements, don't hang Mozilla.

I'm using Mozilla 1.2.1 with Flash plug-in 6.0r67, on a 400MHz TiBook with 384MB
of RAM.
i would like to know if it's a problem macromedia has to look into or if it's a
mozilla issue. this bug is pretty annoying. opening more than one window with
flash-content will lock the browser up.
This doesn't lock up on  my dual 1Gig/1.25Gig RAM G4  :)
I think Flash just might be pushing the limits of RAM and CPU usage that your
machine can take. What does 'top' say?
I tried the links in Comment #6 and Comment #10, and they were OK for me.  Flash
took about 70% CPU on my 400MHz G4.  

Then, I command-clicked the link in Comment #6 (new tab, background) and I got
the beachball, the tab took about two minutes to draw, but top went up to 83%
CPU (0% idle) right away.  Once the new tab was drawn and I switched to it,
everything was OK.

Next, I tried opening two tabs with that same link.  I waited about 5 minutes
for it to draw anything, then force-quit it.  I think you're right, this is a
CPU-exhaustion issue.

Now over to the evil empire, I fired up IE and loaded the same URL.  71% CPU,
but the framerate was about twice as fast (clue?).   Then I opened up a second
window with the same URL - the framerate dropped in half, but the CPU stayed at
the same 71%.
QA Contact: shrir → bmartin
*** Bug 184035 has been marked as a duplicate of this bug. ***
*** Bug 195857 has been marked as a duplicate of this bug. ***
This now WFM using the 2003081810 build, and the latest (beta) Flash plugin (7.0
d249). I believe the latest plugin addresses the majority of CPU hangs and usage
for flash content in the majority of OS X browsers, as I've seen a CPU decrease
in Safari and Mozilla, also.

All of the comment URLs load fine, with a reasonable amount of CPU usage on my
1.2ghz Powermac, and my 667ghz Tibook.
Depends on: 217360
Yeah. This works with current flash and seamonkey.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
Verified for OSX plugindoc update Flash 7.0R19
Status: RESOLVED → VERIFIED
Attached file Sample of Hung Mozilla
I'm seeing this again with build 2004042110 and Shockwave Flash 7.0 r19.

http://www.whotel.com (redirects somewhere but I cant't hang right now to get
the final URL.)

Attaching a sample; all the CPU is definately in the plugin.  I'll wait to see
if there are any comments before reopening.  I noticed there are several linux
and windows reports of the same issue, so if this isn't a problem on IE, e.g,
is it still a problem with Flash?
You need to log in before you can comment on or make changes to this bug.