Closed Bug 1721950 Opened 3 months ago Closed 3 months ago

Beginning with Firefox 90.0.0 the master password dialog box pops up multiple times, seemingly randomly, and after successfully entering the correct master password.

Categories

(Toolkit :: Password Manager, defect)

Firefox 90
defect

Tracking

()

RESOLVED DUPLICATE of bug 1721084

People

(Reporter: briandelshasta+ffbug, Unassigned)

Details

(Whiteboard: [passwords:primary-password])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

Steps to reproduce:

Open Firefox on multiple computers, enter master password to enable sync to other devices.

Actual results:

Sync begins, access to saved passwords works, but later the master password will popup again and again for no purpose. If I leave the computer for a couple hours I can have several master password prompts waiting for me. They seem benign as closing them has no effect. Access to stored passwords and sync continue normally.

Expected results:

The master password prompt should not popup at all again after entering the correct password and granting sync and saved password access. This is how FF behaved prior to version 90.0.0.

HTTP Authentication prompts also start popping up again after a while in Firefox 90, so it seems like there is some event that is firing and requesting all logins again for some reason. The last time this happened to me it was approximately 1d10h since the previous authentication, which is suspiciously close to 2000 or 2048 minutes. There were no relevant messages in Browser Console.

UA: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:90.0) Gecko/20100101 Firefox/90.0

Hi Brian Del Shasta and Colin,
Thanks for the report!

Could you please answer the following questions in order to further investigate this issue?

1- Are you using add-ons? If so could you please list them? (you can try the issue while in Safe Mode. You can find helpful info here : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode .)
2- Does this issue occur in the latest nightly version of firefox? Here is a link from where you can download it: https://www.mozilla.org/en-US/firefox/channel/desktop/

I've assigned a component in order to get the dev team involved, but if it's not relevant, please feel free to change it to an appropriate one.
Best regards, Clara.

Component: Untriaged → Password Manager
Flags: needinfo?(briandelshasta+ffbug)
Product: Firefox → Toolkit
Flags: needinfo?(mozbugzilla2021)
Whiteboard: [passwords:primary-password]

Hi Clara,

Enabled non-default extensions here are:

Cookie AutoDelete 3.6.0 [CookieAutoDelete@kennydo.com]
h264ify 1.1.0 [jid1-TSgSxBhncsPBWQ@jetpack]
Netflix 1080p 1.16.0 [{f18f0257-10ad-4ff7-b51e-6895edeccfc8}]
uBlock Origin 1.37.0 [uBlock0@raymondhill.net]
uMatrix 1.4.4 [uMatrix@raymondhill.net]
User-Agent Switcher and Manager 0.4.7.1 [{a6c4a591-f1b2-4f03-b3ff-767e5bedf4e7}]

Since I don’t know what is causing this event, and when it happens it seems to take at least a full day to trigger, it’s unfortunately not tractable for me to try to reproduce it with safe mode/nightly. It seems like it must be configuration-related since otherwise I would expect more reports.

I subsequently noticed that after the authentication re-request occurred, I lost at least one cookie. While doing research, I learnt that Cookie AutoDelete can’t delete some cookies when Strict mode is enabled due to dFPI, so I’ve turned off Strict mode. Brian, do you happen to have Strict mode ETP enabled too? I don’t know a thing about how ETP interacts with things like master password/HTTP auth but I wonder if something has changed there in Fx90. I’ll report back on whether or not I see this problem happen again now that I’ve changed this.

Thanks,

Flags: needinfo?(mozbugzilla2021)

No Strict mode ETP, only Standard here.
The only 3rd party extensions I'm using are uBlock Origin v1.37.0 and NoScript v11.2.10.

It does now seem to only trigger once per day now that I've watched it further. When it triggers however, it prompts for master password twice in close succession. This means when I return to a computer each day there are two master password prompts waiting. Whether I cancel them or enter the real or even wrong master password makes no difference. Access to saved passwords still works normally regardless, because I already entered the master password correctly upon the original startup of Firefox.

Flags: needinfo?(briandelshasta+ffbug)

Make that three times in quick succession.

Additionally, I see now too that when they pop-up I am indeed kicked off firefox sync and do lose access to the saved passwords in the local database.

I too have this problem. And on several installations (PCs).
I have a number of plugins, but none are the same as those Colin S mentions:

Adblock Plus
Close Tab Button
Copy PlainText
CSS Exfil Protection
Don't touch my tabs
Enhancer for Youtube
Facebook Container
Firefox Multi-Account Containers
Flickr Fixr
Greasemonkey
Image Search Options
JetBrains Toolbox Extension
Max Tabs
Notifier for Feedly
Search by Image
Social Fixer for Facebook
Translate Now
Undo Close Tab
Video DownloadHelper
Want My RSS
Web Archives
xIFr

(In reply to Stig Nygaard from comment #7)

I too have this problem. And on several installations (PCs).

Yes, this occurs on every instance of Firefox I have across 4-5 different computers.

Just now I had two Password Request dialogs open when I returned to PC (Browser and PC has probably been running 7-8 hours, and maybe it is an hour since I last touched it). I tried cancelling both dialogs, and then selected "Synchronise now". I was prompted again with the "Password Required" dialog, so it seems it somehow loses contact? I could login/connect again without problem.

Exactly like the described in my previous comment, happened yesterday and today.
I turn on PC and open browser in the morning, and at some point returning to it during the afternoon, I see two Password Request dialogs open. I cancel them, and try to trigger synchronization and get the prompt again. I then connect and don't see the prompts anymore during the day.
It seems to be consistently same behaviour every day I open PC in the morning, and keep PC/browser running during the day.

Thank you for filing the bug, I have seen several bugs reporting this issue (after FF 90).
I'll investigate this issue. I'll track this in Bug 1721084 so mark this bug as a duplicate of Bug 1721084.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1721084
You need to log in before you can comment on or make changes to this bug.