Crash when trying to browse "back" after the PDF file failed to be generated

VERIFIED WORKSFORME

Status

()

Firefox
General
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Loic Fabro, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From a web application, I try to access an ASP page that generates a PDF. The 
ASP set the content-type correctly and Phoenix starts the PDF plug-in. However, 
the PDF generation failed. As a result, I get the error "the file does not 
start with "%PDF". (Everything is fine until now! ;-) ).

Once I got the popup message, I click on the "back" button to browse back to 
the previous page => Crash. The "Netscape Feedback Agent" kicks off to try to 
send the error report (but will never be able to do so as we are using a 
Microsoft Proxy server here....).
(Reporter)

Comment 1

16 years ago
Phoenix 0.2 (build 20021001)

Comment 2

16 years ago
without a stack trace (or talkback report) this bug isn't going to be of any
use. Without that or a testcase we're not going to be able to do anything with
this bug. sorry. 

Comment 3

16 years ago
Confirmed on Win98 with Mozilla build 2002100714 (crashes Phoenix here too)

Visit: http://prdownloads.sourceforge.net/jboss/JBoss.3.0QuickStart.Draft3.pdf

Should bring up the Sourceforge download mirrors page, but instead brings up a
pop-up saying "the file does not start with '%PDF'".

Clicking on the location bar and hitting enter (i.e., re-requesting the page)
results in crash.  (Talkback ID: TB122524OX)

Comment 4

16 years ago
Phil, that talkback incident doesn't seem to exist. are you sure you typed the
correct number? 

Sounds like it could be bug 122783  Have you tried a recent Mozilla build to see
if you get the same crash?

Comment 5

16 years ago
Oops, 0 and O confusions...  Doesn't look at all like bug 122783 to me, but I
may be wrong.

Crashes Mozilla 2002100808 on Win 98.

Talkback ID TB12293527K

Comment 6

16 years ago
No crash with build 2002101010, but the behaviour is still wrong.  Would someone
like to open a new bug for the Sourceforge .pdf download problem?  (Works on
Netscape 4.8, IE6SP1)

Comment 7

16 years ago
I could not reproduce crash with Phoenix nightly 20021017 but could with Mozilla
20021008 (9 days older).  I also get some fun repaint issues in the Mozilla and
Phoenix page area (where pages render) which seem to be due to the Adobe Acrobat
plugin not repainting.  Using Win2K SP3 and Adobe Acrobat reader 5.0.5.

What seems to happen is that Mozilla and Phoenix are trying to open an HTML file
which has an extension of .PDF by starting the Acrobat plugin.  It is the plugin
which returns error message:  File does not begin with '%PDF-'.

In IE 6 SP1 the page comes up as HTML and contains a list of mirror servers to
load the actual PDF from.

I'm unsure if this is a Mozilla issue (page handling), an Acrobat issue
(doubtful), a server MIME issue (maybe making Mozilla revert to file extensions
to resolve type), or something else.  The fact that the issue occurs in Mozilla
and that the error message comes from a plugin means this shouldn't be a Phoenix
bug.  I have insufficient permissions to change "Product", which is as it should
be, so someone else will need to change the bug assignment or file a more
correct bug.

My Mozilla crash is reported in Talkback Incident ID TB12805321H.  There was no
crash in Phoenix, thus no report.

Comment 8

16 years ago
I'm using Win2k SP3, 20021020, 1024x768. When launching the URL I get a popup
window with the following message "File doesnt not begin with '%PDF-'" I press
ok and get lots of repaint problems in the menus. This only happens (the repaint
issue) when launching this site only, in a single tab without any other tabs
open. If I open this site in a new tab, I can close the tab and continue work
without any problems.

Comment 9

16 years ago
wfm

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021020 Phoenix/0.3,
build 200210200

Tried examples from this one and 122783.  All using gv as my system default.  No
problems.

Comment 10

16 years ago
wfm
tried source forge link and page opens properly I get pdf plugin read document
and go back.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021021 Phoenix/0.3

Comment 11

16 years ago
Created attachment 103737 [details]
Valid HTML doc with a .PDF extension, served as text/plain

Not sure if this will work, but trying to create a simple test case by serving
a valid HTML 4.01 Transitional file as text/plain.  This should fool Mozilla
and Phoenix into loading the Acrobat Reader plugin because the file has a .PDF
extension, not a valid HTML extension (.HTM, .HTML, etc.).

Updated

16 years ago
Attachment #103737 - Attachment mime type: text/plain → text/foo

Comment 12

16 years ago
One half of the bug (the crash) seems to have been solved sometime in the
October 8-10 range (based on crash/no crash reports here) and hasn't been
reproduced in Mozilla or Phoenix since 20021010.  I suggest closing this bug for
this reason.

The remaining half of the issue (the error message) looks to be caused by
serving a file with no MIME type and a .PDF extension, but with HTML contents. 
This wouldn't be a bug at all because the Mozilla/Phoenix plugin system is meant
to fall back to file extensions when lacking an MIME type to go by.

It seems that the Sourceforge test doesn't exhibit problems anymore because the
server is now applying a valid MIME type (text/html) to the old example file:

http://prdownloads.sourceforge.net/jboss/JBoss.3.0QuickStart.Draft3.pdf

Sorry about the attachment SPAM from a minute ago, though.  I was trying to
create a testcase for the second half of the issue, but because the Bugzilla
system won't serve a file without an MIME type, my testcase won't work.

If I leave my testcase as text/plain, Phoenix renders it as plain text.  If I
make a fake MIME type (text/foo), Phoenix complains that it doesn't know what to
do with it and asks to save the file (as expected).  I am unable to leave the
MIME type completely out (Bugzilla yells at me for leaving the field blank).

Updated

16 years ago
Attachment #103737 - Attachment mime type: text/foo → application/foo

Updated

16 years ago
Attachment #103737 - Attachment mime type: application/foo → text/foo

Updated

16 years ago
Attachment #103737 - Attachment mime type: text/foo → text/plain

Comment 13

16 years ago
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021022 Phoenix/0.3

Sourceforge shows the mirrors, the attachment link shows plain text,
can´t crash.

Comment 14

16 years ago
Works perfectly for me now (build 2002102208).  Time to close the bug.  Thanks
everyone.

Comment 15

16 years ago
As per comments 12, 13 and 14, I'm closing this bug as WFM as users other than
the reporter were able to confirm the problem initially and subsequently found
the problem to have been solved on a later build.

Reporter: lesfabro-res@altern.org (Loic Fabro),

if you disagree, please reopen if you can successfully reproduce with a recent
build and report the results back here.

This is the oldest outstanding unconfirmed Phoenix 'bug', and we'd all
appreciate seeing it resolved in some form ;-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 16

15 years ago
VERIFIED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030714
Mozilla Firebird/0.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.