This URL (PDF document) hangs mozilla (Adobe Acrobat 5.0.0)

RESOLVED WORKSFORME

Status

()

P2
critical
RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: coffeebreaks, Assigned: peterl-bugs)

Tracking

({hang})

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awaiting info from reporter], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2b) Gecko/20020930
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2b) Gecko/20020930

When I click on the link
javascript:PopupWindowScroll('/CourseOutline/microsoft/M2349.pdf','Outline',700,500,-150,-150)

My browser hangs. Problem does not appear with mozilla 1.1 on Debian Linux unstable.

Reproducible: Always

Steps to Reproduce:
1. Load the URL
2. Click on the link "Programming the Microsoft .NET Framework with C#" (sorry
for that :))
3. watch the browser hang




Note: When the page loaded, before I clicked on the javascript link, there was a
request to load a chinese font. I cancelled it.
(Reporter)

Comment 1

16 years ago
Accessing the URL directly also hangs the browser. Modified URL.
Summary: Clicking on a link to a javascript popup loading a PDF hangs mozilla → This URL (PDF document) hangs mozilla

Comment 2

16 years ago
WFM - trunk build 2002100208 - WinXP - Acrobat Reader Plugin 5.0.5
(Reporter)

Comment 3

16 years ago
btw, forgot to precise I tried under a different profile.
-> Plugins for now...

Do you use the Acrobat Plugin ?
(see help/about plugins)

if yes: which version ?
Assignee: asa → beppe
Component: Browser-General → Plug-ins
Keywords: hang
QA Contact: asa → shrir
(Reporter)

Comment 5

16 years ago
From About Plugins:

Adobe Acrobat

  File name: nppdf32.dll
  Adobe Acrobat Plug-In Version 5.00 for Netscape

MIME Type         Description   Suffixes   Enabled
application/pdf   Acrobat       pdf        Yes

I had installed this mozilla into a fresh directory using the zip file with
talkback enabled. I didn't install any plugin, they got detected by Mozilla.

Comment 6

16 years ago
odd - I went to test the referenced page and it is not there, I get the:
The page cannot be found
The page you are looking for might have been removed, had its name changed, or
is temporarily unavailable.

Reporter: can you direct me from their home page as to how to reach that PDF?

Comment 7

16 years ago
WFM http://www.infocanhk.com/CourseOutline/microsoft/M2349.pdf
also as original test case:
http://www.infocanhk.com/itskills/schedule/CourseList.asp?Group_ID=MSCP07
tested on w2k, mozilla debug build 20021003, acrobat 5.05

Comment 8

16 years ago
does not hang for me..but does not even load , I see a blank page displayed.

Comment 9

16 years ago
The reason you see nothing Shrir is because the blank page is really a html
error page -- do a view source and you will see the error page content.

To access the page, do the following
1. go to http://www.infocanhk.com/corporate/index.htm
2. select under Skill Transfer and Training on the left-hand side - Training
Schedules. A secondary page will be displayed, titled Skill Transfer and Training.
3. from the pop-up page, refer to this section:
   Microsoft Certification Programs
   . Microsoft .NET

   select Microsoft .NET

   The pop-up will update to a listing of all the Microsoft course, scroll down
   till you see this line:
   M2349   Programming the Microsoft .NET Framework with C#    18  6500

4. select the text string
   Programming the Microsoft .NET Framework with C#

   another pop-up will be displayed, this pop-up contains the PDF file. 
   the window does not contain the browser menu list, or controls

The page renders correctly using a build from today (20021007) on win98
   

Comment 10

16 years ago
hm, I thought I commented here in this bug:
oh well,
Thansk for the great steps beppe ! I actualyl see the pdf loading jsut fine on 
my NT with 1007 trunk build. 
(Reporter)

Comment 11

16 years ago
- I just downloaded the latest and I still see this behavior
- bug 173061 seems like a potential dupe. 

Any way to know in which part of the code the browser hangs?

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 12

16 years ago
Jerome: Can you please do the following for us and attach to this bug.

1. Bookmark http://www.infocanhk.com/corporate/index.htm
2. Close the browser
3. In your environment variable file, please add teh following:
SET NSPR_LOG_MODULES=Plugin:5,PluginNPN:5,PluginNPP:5,nsHTTP:5
SET NSPR_LOG_FILE=C:\pluginlog.txt

4. Open the browser and go directly to the above URL, follow the steps as
defined in comment #9. When the PDF page displays, and presuming it does not
work, close the browser completely.

5. Remove the environment variables
6. Reopen the browser and attach the pluginlog.txt file to the bug

We will be able to follow the process and possibly determine what the problem is.
Whiteboard: [awaiting info from reporter]

Comment 13

16 years ago
dup of bug 131007?
(Reporter)

Comment 14

16 years ago
Created attachment 102315 [details]
pluginlog (zipped) as requested

vaer så god

Comment 15

16 years ago
I believe I am experiencing the same problems. Any time I try to open a PDF
document in Mozilla (same window or new window, doesn't matter), all I see is a
blank page but the browser window still responds (I can move it around, etc.).
However, once I try to go somewhere else (go back, enter new URL, etc.) the
browser stops responding and my CPU usage jumps to 100%. It almost acts as
though Mozilla enters some sort of endless loop, because the window just sits
there and "flickers" every 5 seconds or so, but the only way I can close it is
to kill the Mozilla process.

Comment 16

16 years ago
Oh, by the way I am using:

Mozilla 1.2a: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a)
Gecko/20020910

Adobe Acrobat Plug-In Version 5.00 for Netscape
File name: nppdf32.dll

Windows XP (ver 5.1.2600)
(Reporter)

Comment 17

16 years ago
Shawn,

it may be that one or bug 131007. I don't know up to which point the two bugs
are related.

Jerome

Comment 18

16 years ago
the log file (attachment 102315 [details]) is incomplete
it shows that content of  http://www.infocan.net/CourseOutline/microsoft/M2349.pdf
was never been fetched completely:(
Jerome, did you try directly access that url? 

Comment 19

16 years ago
reassign
Assignee: beppe → peterl

Updated

16 years ago
Priority: -- → P2
Target Milestone: --- → Future

Comment 20

15 years ago
Either this or bug 204550 may be a duplicate of the other (depending on which
comments you want to save), at least it looks like a lot of "PDF's don't work"
dupes are showing up there.
Summary: This URL (PDF document) hangs mozilla → This URL (PDF document) hangs mozilla (Adobe Acrobat 5.0.0)

Comment 21

13 years ago
WFM

I cannot reproduce this bug either with acrobat 6, 6.04, 6.05, or 7 on the trunk or in 1.5 (windows xp, acrobat told me to update when I first opened the link, so I figured I'd test it with each while upgrading).

This bug appears not to have been touched in a couple years. Is there still installations of acrobat 5 hanging around that can test this (and should they be cared for, or told to upgrade)?

Comment 22

12 years ago
closing WFM per comment 21. 
cannot confirm because all the reference URLs don't work.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
QA Contact: shrir → plugins
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.