Closed Bug 1723293 Opened 1 year ago Closed 1 year ago

Today Pane: Filter tasks doesn't work

Categories

(Calendar :: Tasks, defect)

Thunderbird 91
x86_64
All
defect

Tracking

(thunderbird_esr91+ verified, thunderbird91 affected)

VERIFIED FIXED
92 Branch
Tracking Status
thunderbird_esr91 + verified
thunderbird91 --- affected

People

(Reporter: je, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:90.0) Gecko/20100101 Firefox/90.0

Steps to reproduce:

Thunderbird 91.0b5 (64-bit) on Linux 5.8.0-63-generic #71~20.04.1-Ubuntu SMP x86_64
Calendar syncs with owncloud 10.7.0.4 using TB's CalDAV, no Calendar Extension installed

  1. Add tasks in owncloud
  2. Sync the calendar
  3. Open the "Today pane"
  4. Switch Today pane to "Tasks" or "Events and Tasks" view
  5. Right-click in the Tasks view in the Today pane to open the context menu
  6. Choose "Filter Tasks"
  7. Chose any option from the submenu

Actual results:

The filter doesn't change, the same Tasks are visible and if you repeat steps 1-6 above, the submenu still shows "Current Tasks".

Expected results:

The filter should change to the selected one.

Tried 91.0b5 (64-Bit) on Windows 10 Pro 21H1 64Bit with the same wrong result.

I see the same with the Home calendar on my computer using Thunderbird 91.0b5 on Fedora 34 Workstation.

Status: UNCONFIRMED → NEW
Component: Untriaged → Tasks
Ever confirmed: true
Keywords: regression
OS: Unspecified → All
Product: Thunderbird → Calendar
Hardware: Unspecified → x86_64
Blocks: tb91found
Assignee: nobody → geoff
Status: NEW → ASSIGNED

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/c1f5b0bf7260
Stop using a command to filter tasks in the Today Pane. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch

Missing uplift request here?

Flags: needinfo?(je)
Flags: needinfo?(geoff)

There's nothing to uplift to right now. 92 beta begins this week.

Flags: needinfo?(je)
Flags: needinfo?(geoff)
Duplicate of this bug: 1725757

Comment on attachment 9234184 [details]
Bug 1723293 - Stop using a command to filter tasks in the Today Pane. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): not sure, something m-c broke a long time ago, I suspect
User impact if declined: tasks can't be filtered in the Today Pane
Testing completed (on c-c, etc.): in 92.0b1
Risk to taking this patch (and alternatives if risky): low

Attachment #9234184 - Flags: approval-comm-esr91?

Comment on attachment 9234184 [details]
Bug 1723293 - Stop using a command to filter tasks in the Today Pane. r=mkmelin

[Triage Comment]
Approved for esr91

Attachment #9234184 - Flags: approval-comm-esr91? → approval-comm-esr91+

Verified testing the 91.0.3 release, release candidate on Windows 10.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.