Print preview reloads a completely loaded page again and often hangs then

VERIFIED WORKSFORME

Status

()

Core
Print Preview
--
major
VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Frank Klemm, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
Build Identifier: Mozilla/5.0 (unknown) unknown

(Can the text box for "Details" be enlarged so I see more than 5 lines ???)

Print preview reloads a completely loaded page again and often hangs then.

This especially occures when Page Setup is called again and again to fine tune
the page layout to avoid nasty page breaks. Doing this very often often cause a
hang up. "Transfering data from ...." is printed in the last line and this
never ends. Only leaving the Print menu and pressing Reload in the main window
helps for a short time.

Occures under Linux and Windows 2000 (the OS I often use).


Reproducible: Sometimes

Steps to Reproduce:
1. Enter page listed above
2. "Print preview"
3. Change parameters (Size percentage) in "Scale" multiple times
4. Typically after the 2nd change the page is tried to reload and this
   never ends.

Actual Results:  
Changed parameter is not used because redisplaying takes infinite time.

Expected Results:  
Display the page using the new paranmeters, and this without reloading any
byte from the webpage displayed and very quickly.
(Assignee)

Comment 1

15 years ago
It doesn't reload the page, it uses the same content model. It only recreates
the visible portion. I have not seen any of the other issues you describe. I
have Win2k.
(Assignee)

Comment 2

15 years ago
your build is from the end of May, try a newer build.

Comment 3

15 years ago
no response from reporter for >60 days, resolving WORKSFORME.

reporter: if you can reproduce this bug with a recent build of mozilla (for
example, 1.2.1), please reopen this bug and give details. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.