Closed Bug 1723799 Opened 3 months ago Closed 3 months ago

Collect height for the visible video play time as well

Categories

(Core :: Audio/Video: Playback, task, P2)

task

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox92 --- fixed
firefox93 --- fixed

People

(Reporter: alwu, Assigned: alwu)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Currently we only collect height for invisible video, and it would be great if we can collect that for visible video as well.

Depends on D121680

Assignee: nobody → alwu
Attachment #9234730 - Flags: data-review?(chutten)

Comment on attachment 9234730 [details]
Request for Data Collection Renewal

PRELIMINARY NOTES:
Despite the file name, this is a full review not a renewal.

DATA COLLECTION REVIEW RESPONSE:

Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes.

Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, Alastor Wu is responsible.

Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 1, Technical.

Is the data collection request for default-on or default-off?

Default on for all channels.

Does the instrumentation include the addition of any new identifiers?

No.

Is the data collection covered by the existing Firefox privacy notice?

Yes.

Does the data collection use a third-party collection tool?

No.


Result: datareview+

Attachment #9234730 - Flags: data-review?(chutten) → data-review+
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ec32e714bc0e
part1 : collect height for visible video playtime. r=padenot
https://hg.mozilla.org/integration/autoland/rev/5984d69367e2
part2 : add test. r=padenot,webidl,smaug
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Comment on attachment 9234580 [details]
Bug 1723799 - part1 : collect height for visible video playtime.

Beta/Release Uplift Approval Request

  • User impact if declined: This is telemetry probe which users won't feel about. We just wanted to collect those data as quick as possible because on Beta there are more users and the result would be more valuable and boarder than the result on Nightly.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): These patches only include adding the telemetry probe and the automation test, no new feature or big change was added.
  • String changes made/needed: no
Attachment #9234580 - Flags: approval-mozilla-beta?
Attachment #9234581 - Flags: approval-mozilla-beta?

Have we confirmed that we're getting sane-looking telemetry data from Nightly builds?

Flags: needinfo?(alwu)

This telemetry probe shares the same logic of another probe (VIDEO_PLAY_TIME_MS) that we've been monitoring for a while and we are pretty sure that data is reasonable. The probe I added here is just adding a key-value pair to collect play time for different sizes of video. In addition, I can confirm that the collected data on Nightly looks reasonable as well. Thank you.

Flags: needinfo?(alwu)

Comment on attachment 9234580 [details]
Bug 1723799 - part1 : collect height for visible video playtime.

Thanks for confirming. Approved for 92.0b3.

Attachment #9234580 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9234581 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.