Closed Bug 1723951 Opened 2 months ago Closed 2 months ago

Icons for Bookmark Toolbar and Other Bookmarks from Customized Bookmark menu missing

Categories

(Firefox :: Bookmarks & History, defect, P2)

Firefox 92
Desktop
All
defect

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox90 --- unaffected
firefox91 --- unaffected
firefox92 --- verified
firefox93 --- verified

People

(Reporter: aflorinescu, Assigned: Gijs, NeedInfo)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

[Environment:]

Windows 10, Mac 11, Mac 10.15, Mac 10.14

[Steps:]
  1. Open Firefox
  2. Open Hamburger menu/ More Tools/ Customize.
  3. Drag and drop the Bookmarks Menu to toolbar.
  4. Close Customize and click on the customized Bookmarks icon.
[Actual Result:]

Bookmark Toolbar and Other Bookmarks have no icons .

[Expected Result:]

Bookmark Toolbar and Other Bookmarks have icons (as in the Bookmarks menu from Menu Bar)

[Regression Window:]

Found commit message:
Bug 1720534 - Clean up styles in Bookmarks Menu Button menupopups on Windows 7 and 10. r=desktop-theme-reviewers,dao

Mike, were these intentional removals? If so, we should probably also drop e.g. https://searchfox.org/mozilla-central/rev/4b49a0dc50104e03ecadd1fd1902b27be6b9c0c8/browser/themes/osx/browser.css#152 ; if not, I guess we should put the icons back?

Flags: needinfo?(mconley)

Since we're looking at a cosmetic issue, this is more on the lines of an S4, hence setting as such.

Severity: -- → S4

Hm. This might be right, or it might have been a misinterpretation of the IA deck that got put together for these panels.

Hey Meridel, should the "Bookmark Toolbar" and "Other Bookmarks" item in the Bookmarks toolbar button menu have icons, like we have for the folders? We used to have them, but they got removed for Firefox 89 - was that removal part of the design, or did I misinterpret?

Flags: needinfo?(mconley) → needinfo?(mwalkington)
Attached image Figma.png

According to my records (see screenshot of Figma designs with the placeholder globe icons), both "Bookmark Toolbar" and "Other Bookmarks" item SHOULD have icons. I am not away of any reason why those would have been removed.

Now, at the time we designed this I believe we were waiting on icon delivery so perhaps we need direction on which icons to use? Emanuela, do you recall if we intended for this to be a globe in each case? It seems like the folder would make more sense than the globe...

Flags: needinfo?(mwalkington) → needinfo?(emanuela)

fwiw in the Bookmarks menu on the menubar the icons are appearing correctly. If we decide it should look otherwise we may want to match that menu as well.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Attachment #9237107 - Attachment description: WIP: Bug 1723951 - put icons back for bookmarks toolbar and other bookmarks folders in the bookmarks menu button, r?mconley → Bug 1723951 - put icons back for bookmarks toolbar and other bookmarks folders in the bookmarks menu button, r?mconley

Emanuela is out until after the cutoff for 92 uplifts so if we want to not regress this in 92 we can't wait for her. I'm going to assume that we should at least revert the icons for now, and if we then want to update them some more we can do it in 93/94.

Comment on attachment 9237107 [details]
Bug 1723951 - put icons back for bookmarks toolbar and other bookmarks folders in the bookmarks menu button, r?mconley

Beta/Release Uplift Approval Request

  • User impact if declined: Missing images in the bookmarks menu toolbar button's panel
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial re-addition of classes that get the menuitem their images back (the list-style-image CSS directives are still in the tree anyway)
  • String changes made/needed: Nope
Attachment #9237107 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Priority: -- → P2
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/56280f0a9681
put icons back for bookmarks toolbar and other bookmarks folders in the bookmarks menu button, r=mconley
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Comment on attachment 9237107 [details]
Bug 1723951 - put icons back for bookmarks toolbar and other bookmarks folders in the bookmarks menu button, r?mconley

Approved for 92.0b7.

Attachment #9237107 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified - Fixed in latest Nightly 93.0a1 (build id: 20210820095755) and Beta 92.0b7 (build id: 20210822190301) using Windows 10 and macOS 10.15. The bookmarks toolbar and other bookmarks icons are displayed accordingly in the customized toolbar Bookmarks menu.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.