Closed Bug 1724004 Opened 1 month ago Closed 8 days ago

When will firefox support Backdrop-filter by default?

Categories

(Core :: Layout, enhancement)

Firefox 90
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1618013

People

(Reporter: grandb3rry, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

Steps to reproduce:

It is fairly sad to see a browser such as Firefox which has now been fully redesigned in terms of UI to not support the Backdrop-filter functionaly by default. I do not understand the lack of willingness to implement this?

Hi Arthur,

Do you mean to have layout.css.backdrop-filter.enabled in about:config set to true by default?

Best,
Clara

Flags: needinfo?(grandb3rry)

I'd also like to push for this!
This special blur effect is an absolut design trend. There Thousand of YT Tutorials how to implement this in you webdesign but none of them tells their followers that it doesn't work in firefox. The result is, that thousand of websites don't work correctly in FF.

And you know: At the end no one will say "what a ugly webdesign", they will say "Use Chrome, it looks nice in chrome".

Flags: needinfo?(meisterleise)

(In reply to Clara Guerrero from comment #1)

Hi Arthur,

Do you mean to have layout.css.backdrop-filter.enabled in about:config set to true by default?

Best,
Clara

Hi, essentially the css class filter (backdrop-filter) etc.

All other browsers support this and it boggles my mind why firefox haven't enabled this by default? It's 2021 guys! :)

Flags: needinfo?(grandb3rry)

(In reply to Clara Guerrero from comment #1)

Hi Arthur,

Do you mean to have layout.css.backdrop-filter.enabled in about:config set to true by default?

Best,
Clara

Hi Clara, yes it is exactly that! :)

Thanks Arthur for suggesting this enhancement.
I'll involve the dev team to get an opinion on this.

Flags: needinfo?(meisterleise)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Is this not tracked here already? https://bugzilla.mozilla.org/show_bug.cgi?id=1578503

The Bugbug bot thinks this bug should belong to the 'Firefox::Installer' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Installer
Component: Installer → Layout
Product: Firefox → Core
Status: NEW → RESOLVED
Closed: 8 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1618013
You need to log in before you can comment on or make changes to this bug.