Closed Bug 1724013 Opened 10 months ago Closed 9 months ago

Orca & Ubuntu fails to read all text and just says "TAB"

Categories

(Firefox :: Disability Access, defect)

Desktop
Linux
defect

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox90 --- unaffected
firefox91 --- unaffected
firefox92 --- wontfix
firefox93 --- verified
firefox94 --- verified

People

(Reporter: muirpablo, Assigned: eeejay)

References

Details

(Keywords: regression)

Description
Orca & Ubuntu fails to read all text and just says "TAB"

Affects all these Os
Ubuntu 20

Affected
Firefox nightly 92.0a1 affected
Firefox beta 91.0 not affected because it acts differently
Firefox release 90.0.2 not affected because it acts differently

Preconditions
-Make sure firefox is already set as default browser, in order to avoid a different result.
or avoid the popup asking you if you want it default at launch.
-ORCA screen reader is ON.

Steps to reproduce

  • Launch new profile.
  • go to about:config
  • change accessibility.blockautorefresh = true
  • change devtools.chrome.enabled = true
  • Close firefox
  • move OS date more 60 days, example october 26
  • Launch firefox and use the same profile.
  • In nightly: it reads the "refresh firefox infobar" below the URL bar
  • In beta:, it will not read it
  • In Release:, it will not read it.
  • start pressing TAB key

Actual result
when i press TAB it only says "tab, tab, tab" not usefull, it gets stuck no matter what area you are it does not read it
it only says TAB when you press the tab key

expected result
it should say TAB and should ALSO speak the place or location you are selecting.
For example if i start pressing tab i should end up saying "save to pocket" or should tell you
the "refresh firefox infobar" text, and should tell you that you are on the allow button, but it only say "TAB"

Notes the result is different in beta & Release because as soon as you launch firefox it does not read the refresh firefox infobar., it just reads data from urlbar. but when you press tab you can reach the infobar text and it does read it.

This sounds like a regression. Unknown if S2 is a proper severity. Lower it if believed to be the right choice.

Severity: -- → S2
Keywords: regression

I can't reproduce this issue. I also can't seem to get that update infobar to show up. I use this site to bring up infobars: http://dummysoftware.com/popupdummy_testpage.html

Pablo, can you provide a video of this not working?

Flags: needinfo?(pablo.muir)

Hi Eitan

Im not using that site, just changing the date of the OS to force a message (below the url bar)
i have uploaded a video with direct audio with all the process. Just need to make sure that firefox nightly is default browser.

video can be downloaded here: https://www.mediafire.com/file/t6ashgzzupc41rm/simplescreenrecorder-2021-08-09_11.40.45+(2).mp4/file

Check after i restart firefox, it will just say "tab"
and if i start pressing shift+ tab, it will just say "left shift"

Flags: needinfo?(pablo.muir)

It appears that the reporter (Pablo) cannot complete the entire process that reproduces the issue in mozregression builds because the toolbar does not appear. Furthermore, I've tried reproducing it on 3 other systems with the same steps without success.

This being said, I will lower the severity since it is not consistently reproduced across Ubuntu OS systems, but specific to one; We'll attempt investigation with other infobars. I have to say that the steps taken to reproduce are quite complicated. There are many things that could have caused it. If anyone has suspicions of specific causes that might be worth investigating, please comment here.

Severity: S2 → S3

Jamie, is that important for accessibility?

Flags: needinfo?(jteh)

Pablo, can you still reproduce this on latest Nightly? I'm wondering whether it might be fixed by bug 1723563.

Flags: needinfo?(jteh) → needinfo?(pablo.muir)

Hi james,

It works now.
I verified the fix with ubuntu 20 64bit and now works on Firefox 93.0b2 beta, nightly 94.0a1 and release 92.0

do you want me to change the bug to resolved-worksforme?

Flags: needinfo?(pablo.muir) → needinfo?(jteh)
Assignee: nobody → eitan
Status: NEW → RESOLVED
Closed: 9 months ago
Depends on: 1723563
Flags: needinfo?(jteh)
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

verified.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.